Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Отсортировать массив из N целых

10-11 класс

чисел в неубывающем порядке с помощью сортировки прямыми вставками На языке С++

Nadjaageeva4 11 окт. 2013 г., 9:20:16 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nagikh
11 окт. 2013 г., 11:09:49 (10 лет назад)

#include <stdio.h> #include <stdlib.h> void build(int*, int ); void heap(int*, int); int main(void) { FILE *fin; int *a,n,i;   fin=fopen("input.txt", "r");   fscanf(fin,"%d", &n); a=(int*)malloc(n*sizeof(int)); for (i=0; i<n; i++) fscanf(fin,"%d", &a[i]); printf("pervona4alniy vid\n"

+ 0 -
Antonburyak99
11 окт. 2013 г., 12:34:21 (10 лет назад)

ща бцудет

+ 0 -
КатеринаФедорова
11 окт. 2013 г., 13:22:32 (10 лет назад)

спасибо за быстрый ответ можно как то по понятнее пожалуйто

+ 0 -
Cap111
11 окт. 2013 г., 15:34:39 (10 лет назад)

первой строке входного файла находится число n - кол-во чисел в массиве. Во второй строке находятся n целых чисел.

+ 0 -
Wwwkrepost72
11 окт. 2013 г., 18:24:54 (10 лет назад)

а это код на с++

Ответить

Другие вопросы из категории

1)В

программе описан одномерный целочисленный массив с индексами от 0 до 10. В
приведенном ниже фрагменте программы массив сначала заполняется, а потом
изменяется:

Читайте также

ПАСКАЛЬ.1)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 1000.опишите на русском языке или на одном из

языков программирования алгоритм,позволяющий найти среднее арифметическое нечетных трехзначных чисел,записанных в этом массиве.если ни одного такого числа нет,нужно вывести сообщение об этом.
2)дан целочисленный массив из 30 элементов.элементы массива могут принимать целые значения от 0 до 100.опишите на русском языке или на одном из языков программирования алгоритм,позволяющий найти и вывести произведение элементов массива,которые имеют четное значение и не оканчиваются на 0.

Составить программу на языке Паскаль: 1)Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2)В массиве М из 10 целых

чисел найти количество элементов равных 3. 3)В массиве из 8 целых найти номер массива с наибольшим значением. 4)В массиве из 12 целых чисел найти количество и сумму элементов, расположенных до максимального элемента. 5)Для массива из 15 вещественных подсчитать количество элементов массива меньших суммы первого и последнего элементов массива.

1)дан одномерный массив из 5 элементов.найти сумму положительных элементов. 2)Дан одномерный массив из 7

элементов.Найти колличество четных положительных элементов.

3)Дан массив из 6 элементов.Найти произвдение положительных из них.

дан массив из семи элементов написать программу подсчитывающую

среднее второго и предпоследнего элементов массива
дан целочисленный
массив из 10 элементов написать программу находящую сумму элементов
массива красных 3 ил 5
дан целочисленный массив из 30 ти элементов
написать программу которая позволяет найти среднее арифметическое
положительных элементов массива



Вы находитесь на странице вопроса "Отсортировать массив из N целых", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.