Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти пять наименьших натуральных чисел N таких, что N^2 = А^2 + В^2 + С^2, где А, В и С неравные друг другу натуральные числа.

10-11 класс

Lydmila8383 09 февр. 2014 г., 13:46:32 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
78FF
09 февр. 2014 г., 14:50:09 (10 лет назад)

var N: Integer;
begin
  N:=0;
  for var i:=1 to 5 do
  begin
     N:=i*i+(i+1)*(i+1)+(i+2)*(i+2);
     writeln(N);
  end;   
end.

Ответить

Другие вопросы из категории

проверьте, правильно ли я решаю)
Для упорядочивания по возрастанию массива целых чисел из 20 элементов (номера элементов начинаются с 0) начинающий программист написал следующий фрагмент

программы:
For i:=1 to 100 do
For j:=0 to 17 do
If a [j] > a [j+2] then
Begin
T := a [j]; a [j] := a [j+2]; a [j+2] := t
End;
Чему станет равен элемент массива с номером 17, если в начале работы фрагмента в массиве находились числа от 20 до 1 в порядке убывания?

Помогите срочно нужно программирование в паскале !! написать программу!!

1 ввести с клавиатуры последовательность из N чисел и найти максимальное число среди элементов стоящих на чётных местах.
2 Выяснить является ли натуральное число K степенью 3.

Читайте также

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Сумма цифр. Даны два числа А и В. Подсчитайте кол-во натуральных чисел на отрезке от А до В , сумма цифр которых четна. Программа

получает на вход два натуральных числа А и В, не превосходящих 10^9^ А<=В . Программа должна вывести одно число - кол-во натуральных чисел, больше или равных А и меньших или равных В, сумма цифр которых четна.

1) Задано положительное число A. Найти сумм всех четных чисел в интервале от 1 до A. Число А может иметь дробную часть.

2) Задано целое положительное число А и В. Найти квадратные корни целых чисел в интервале от А до В. Замечание: A<B

решение - объяснение Сколько существует различных пар натуральных чисел, таких что: Ваш ответ: 86 1. Оба числа, записанные в

шестеричной системе счисления, имеют ровно по три значащих разряда. 2. Сумма этих чисел, записанная в шестеричной системе счисления, содержит только цифры «1». Пары чисел, отличающиеся только порядком следования чисел в паре, считаются одинаковыми. В ответе укажите целое число.



Вы находитесь на странице вопроса "Найти пять наименьших натуральных чисел N таких, что N^2 = А^2 + В^2 + С^2, где А, В и С неравные друг другу натуральные числа.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.