Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Сколько раз встречается минимальная цифра в записи введённого с клавиатуры 4-х значного числа? Помогите плиз!!

5-9 класс

Vismar2010 03 июля 2014 г., 2:39:33 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Drawnranger
03 июля 2014 г., 4:18:34 (9 лет назад)

Program Pr1;
uses crt;
var mas:array[1..4] of integer;
stroka:string;
i,min,b:integer;
Begin
clrscr;
writeln('Vvedite chislo');
readln(stroka);
for i:=1 to 4 do val(stroka[i],mas[i],b);
min:=10;
b:=0;
for i:=1 to 4 do if mas[i]<min then min:=mas[i];
for i:=1 to 4 do if mas[i]=min then b:=b+1;
writeln(b);
end.

Ответить

Другие вопросы из категории

Напишите программу в Turbo Pascal для задачи

Перераспределить значения переменных х,у, z. Выяснить, существуют ли треугольник с длинами сторон x, y, z. Ответ дайте в текстовой форме существуют или не существуют.

на 8 учеников оставшихся в класе на перемене были вызваны где вектору один из них разбил окно в кабинете на вопрос директора кто это сделал были получены

следующие сведения :
Егор : Разбил Андрей
Оля : Разбила Света
Надя : да ,Оля права
Вика : Андрей не бил
Света : Вика разбила
Миша : Это кто-то с улицы
Коля : Это либо Вика , либо Света
Андрей : Ни Вика , ни Света этого не видели .
Кто разбил окно , если известно , что из этих восьми высказывании истинно равна 3 ?
Ответ запишите в виде первой буквы имени .

Читайте также

НАПИСАТЬ ПРОГРАММЫ(ПАСКАЛЬ)

Дано натуральное число.Определить номер цифры 8 в нем,считая от конца числа ,Если такой цифры нет,ответом должно быть число 0,если таких цифр в числе несколько -должен быть определен номер самой левой из них

Дано натуральное число.определить,сколько раз в нем встречается минимальная цифра (например для числа 102200 ответ равен 3,для числа 30330-2)

Найти 10 первых натуральных чисел ,оканчивающихся на цифру 7 кратных числу 9 и находящихся в интервале ,левая граница которго равно 100

• 1В процессе преобразования растрового графического изображения количество цветов уменьшилось с 64 до 8. Во сколько раз уменьшился объем, занимаемый

им в памяти. Контрольная работа по теме «Компьютерная графика» 2 вариант • 2Мультимедиа – это А) получение движущихся изображений на дисплее; Б) прикладная программа для создания и обработки рисунков; В) объединение высококачественного изображения с реалистическим звуком; Г) область информатики, занимающаяся проблемами рисования на ЭВМ. • 3Выберите правильную последовательность этапов развития компьютерной графики: а) Появление графических дисплеев; b) Символьная графика; c) Появление графопостроителей; d) Появление принтера цветной печати. А) a, c, d, b; Б) b, c, a, d; С) b, a, c, d; Г) a, b, d, c. 3. Созданием произвольных рисунков, чертежей занимается А) научная графика; Б) конструкторская графика; В) деловая графика; Г) иллюстративная графика. 4. Какое устройство компьютера осуществляет процесс дискретизации звука? А) звуковая карта; Б) колонки; В) наушники; Г) процессор. 5. Растровое изображение представляет из себя … А)мозаику из очень мелких элементов — пикселей; Б) сочетание примитивов; В) палитру цветов. 6. Точка графического экрана может быть окрашена в один из цветов: красный, зелёный, коричневый, чёрный. Какой объём видеопамяти будет выделен для кодирования каждого пикселя? А) 4 бита; Б) 2 байта; В) 4 байта; Г) 2 бита; Д) 3 бита. 7. Инструментом ГР является: А) Линия; Б) цвет; В) разбрызгиватель; Г) рисунок. 8.Графическим примитивом является: А)линия; Б)ластик; В) копирование; Г)цвет. 9. Для получения 4-х цветного изображения на каждый пиксель необходимо выделить А) 1 байт ; Б) 1 бит; В) 2 байта; Г) 2 бита 10.Дискретный сигнал – это …А) цифровой сигнал; Б) количество измерений, производимых прибором за 1 секунду; В) непрерывно меняющееся со временем значение физической величины; Г) таблица с результатами измерений физической величины в фиксированные моменты времени. 11. При какой частоте дискретизации происходит более точное воспроизведение звука? А) 44,1 кГц; Б) 11 кГц; В) 22 кГц; Г) 8 кГц. 12. Что можно отнести к недостаткам растровой графики по сравнению с векторной? А) Большой объём графических файлов. Б) Фотографическое качество изображения. В) Возможность просмотра изображения на экране графического дисплея. Г) Искажения при масштабировании. 13.Что можно отнести к недостаткам ж\к монитора? А) малый вес; Б) затемнения при изменении угла обзора; В) отсутствие э/м излучения; Г) малый объем. • 14Для кодирования зелёного цвета служит код 1011. Сколько цветов в палитре? • 15Найдите объём записываемого звукового квадроаудиофайла, если запись велась 4 минуты, с использованием 16-битовой глубины кодирования звука и частотой дискретизации 32кГц. • 16Для хранения растрового изображения размером 64 на 64 пикселя отвели 512 байтов памяти. Каково максимально возможное число цветов в палитре изображения? • 17 В процессе преобразования растрового графического файла количество цветов уменьшилось с 512 до 8. Во сколько раз уменьшился информационный объем файла?

Составьте программу, которая определяет, сколько раз встречаются числа x,y, x-y,x+y в последовательности из 50 заданных чисел. Данные с

клавиатурызадаются в таком порядке: x y и 50 чисел. Помогите, пожалуйста, очень надо)



Вы находитесь на странице вопроса "Сколько раз встречается минимальная цифра в записи введённого с клавиатуры 4-х значного числа? Помогите плиз!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.