Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите, пожалуйста, написать программу в Паскаль ABC.. Входящие данные - a,b,c - стороны треугольника. Найти:

5-9 класс

a) Тип треугольника, который получается при построении по хаданным сторонам треугольника;

Hgjuy 08 марта 2014 г., 0:07:44 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Caterina799
08 марта 2014 г., 2:41:55 (10 лет назад)

Программа, выполняющая задачи а, б и г:

var
a,b,c:integer;
p2: real;
cosa,cosb,cosc:real;
begin
write('Введите строну a = ');
readln(a);
write('Введите строну b = ');
readln(b);
write('Введите строну c = ');
readln(c);
cosa:=(sqr(b)+sqr(c)-sqr(a))/(2*b*c);
cosb:=(sqr(a)+sqr(c)-sqr(b))/(2*a*c);
cosc:=(sqr(a)+sqr(b)-sqr(c))/(2*a*b);
writeln;Write('ТРЕУГОЛЬНИК: ');
If c-b-a>=0 Then begin writeln('НЕ СУЩЕСТВУЕТ'); readln; exit end;
If b-c-a>=0 Then begin writeln('НЕ СУЩЕСТВУЕТ'); readln; exit end;
If a-b-c>=0 Then begin writeln('НЕ СУЩЕСТВУЕТ'); readln; exit end;
    If a-b=0 then if c-0=a then write('РАВНОСТРОННИЙ ');
if a-b=0 then if c-0-a<>0 then write('РАВНОБЕДРЕННЫЙ ');
if a-c=0 then if b-0-a<>0 then write('РАВНОБЕДРЕННЫЙ ');
if c-b=0 then if a-0-c<>0 then write('РАВНОБЕДРЕННЫЙ ');
    if a<>b then if a<>c then if b<>c then  write('РАЗНОСТОРОННИЙ ');
if cosa>0 then if cosb>0 then if cosc>0 then Writeln('ОСТРОУГОЛЬНЫЙ');
if cosa=0 then writeln('ПРЯМОУГОЛЬНЫЙ');
if cosb=0 then writeln('ПРЯМОУГОЛЬНЫЙ');
if cosc=0 then Writeln('ПРЯМОУГОЛЬНЫЙ');
if cosa<0 then writeln('ТУПОУГОЛЬНЫЙ');
if cosb<0 then writeln('ТУПОУГОЛЬНЫЙ');
if cosc<0 then writeln('ТУПОУГОЛЬНЫЙ');
writeln('Периметр треугольника равен ',a+b+c);
p2:=(a+b+c)/2;
writeln('Площадь треугольника равна ',sqrt(p2*(p2-a)*(p2-b)*(p2-c)));
writeln('Угол, лежащий напротив стороны a равен ',arccos(cosa):0:4,' радиан');
writeln('Угол, лежащий напротив стороны b равен ',arccos(cosb):0:4,' радиан');
writeln('Угол, лежащий напротив стороны c равен ',arccos(cosc):0:4,' радиан');
readln;
end.

+ 0 -
OzernSM
08 марта 2014 г., 3:29:31 (10 лет назад)

Это всё надо вместить в одну программу?

Ответить

Другие вопросы из категории

Раскодируйте: 100011001100000011000000110111 (ASCII)

100001010100000100010001000110 (ASCII)

Помогите с заданием по информатике. Тема Ветвление

1. Запишите на алгоритмическом языке алгоритм, соответствующий
данной блок-схеме:

6. B 2 . В программе «:=» обозначает оператор присваивания, знаки «+», «-», «*» и «/» — соответственно операции сложения, вычитания, умножения и деления.

Правила выполнения операций и порядок действий соответствуют правилам арифметики. Определите значение переменной a после выполнения алгоритма:
а := 4 b := 2b := a/2*b a := 2*а + 3*b
В ответе укажите одно целое число — значение переменной a.

Модем передает данные со скоростью 7680 бит/с. Передача текстового файла заняла 1,5 мин. Определите, сколько страниц содержал переданный текст, если

известно, что он был представлен в 16-битной кодировке Unicode, а на одной странице – 400 символов.

Читайте также

Помогите,пожалуйста,написать программу по информатике.Вот такое условие:

Составьте программу, которая формирует массив из 40 случайных целых чисел от 0 до 20 и вычисляет:
1). сумму чисел, не превышающих 10;
2). сумму чисел,кратных 3. Помогите пожалуйста,написать эту программу на PaskalABC.

Помогите, пожалуйста, написать программу в Паскаль

Если дано трехзначное число, например 123 его можно представить в виде 3+2*10+1*10*10. Воспользовавшись этой информацией, создайте программу, которая, получая от пользователя трехзначное число, будет определять из каких цифр оно состоит и выводить их через пробел (например, 1_2_3).

Помогите, пожалуйста, написать программу в Паскаль

Напечатать таблицу перевода 1,2,…, 20 долларов США в рубли по текущему курсу (значение курса вводится с клавиатуры).

Помогите, пожалуйста, написать программу на Паскале.

Дана строка. Верно ли, что второе слово начинается на ту же букву, которой заканчивается третье слово?



Вы находитесь на странице вопроса "Помогите, пожалуйста, написать программу в Паскаль ABC.. Входящие данные - a,b,c - стороны треугольника. Найти:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.