Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дан вектор размером n определить является ли числовая последовательность возрастающей ( числа вести в ручную)

10-11 класс

Ashaha 29 июня 2016 г., 17:40:50 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Aramelevy
29 июня 2016 г., 18:16:19 (7 лет назад)

var

  a:array[1..1000] of real;

  n, i:integer;

  check:boolean;

begin

  write('n = '); readln(n);

 

  check := true;

  write('a[1] = ');

  readln(a[1]);

  for i := 2 to n do

  begin

    write('a[', i, '] = ');

    readln(a[i]);

    if a[i - 1] >= a[i] then

      check := false;

  end;

 

  if check then

    writeln('Последовательность возрастающая')

  else

     writeln('Последовательность не является возрастающей');

end.

Ответить

Другие вопросы из категории

как мы получаем информацию?
Найдите натуральное число такое что его запись в семеричной системе счисления имеет ровно четыре значащих разряда и при этом выполняются следующие условия

: Две первые цифры его записи являются одинаковыми между собой и две последние цифры также одинаковы между собой.Две первые цифры отличны от последних двух цифр.
Число является полным квадратом то есть оно является квадратом некоторого целого числа .
В ответе укажите четырёхзначное число в семеричной системе счисления.

Читайте также

Помогите пожалуйста с 2 задачами! 1) Простым числом называется натуральное число p>1, натуральными делителями которого которого являются

только два числа: 1 и P. Определить, является ли введенное с клавиатуры число простым.

2) Дано число n. Верно ли, что это число содержит ровно 3 одинаковых цифры?

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.



Вы находитесь на странице вопроса "дан вектор размером n определить является ли числовая последовательность возрастающей ( числа вести в ручную)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.