Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Программный код решения уравнения x^2-cosx=0

10-11 класс

ShitmanPolina 15 авг. 2016 г., 3:48:24 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
23052006
15 авг. 2016 г., 5:29:31 (7 лет назад)

function f(x: real): real;
begin
    f := x * x - cos(x);
end;

procedure solve(start_x, stop_x, e: real);
var
    step_x, last_f, cur_f, x: real;
begin
    step_x := (stop_x - start_x) / 100;
    x := start_x;
    last_f := f(x);
   
    repeat
        x := x + step_x;
        cur_f := f(x);
       
        if cur_f * last_f < 0 then begin
            if step_x < e then
                writeln(x:20:10, ' ', f(x):20:10)
            else
                solve(x - step_x, x, e);
        end;
       
        last_f := cur_f;
    until x > stop_x;
end;

begin
    solve(-1000, 1000, 0.0000001);
    writeln('END');
end.

+ 0 -
Anprosto
15 авг. 2016 г., 7:28:55 (7 лет назад)

function f(x: real): real;
begin
f := x * x - cos(x);
end;

procedure solve(start_x, stop_x, e: real);
var
step_x, last_f, cur_f, x: real;
begin
step_x := (stop_x - start_x) / 100;
x := start_x;
last_f := f(x);

repeat
x := x + step_x;
cur_f := f(x);

if cur_f * last_f < 0 then begin
if step_x < e then
writeln(x:20:10, ' ', f(x):20:10)
else
solve(x - step_x, x, e);
end;

+ 0 -
НикитосНазаров
15 авг. 2016 г., 9:40:44 (7 лет назад)

last_f := cur_f;
until x > stop_x;
end;

begin
solve(-1000, 1000, 0.0000001);
writeln('END');
end.

Ответить

Другие вопросы из категории

Существует метод шифрования –

шифрование с помощью ключа. Ключом является слово "цель". Таким образом, результатом шифрования слова "информация" с помощью этого ключа
и с учётом того, что за исходный алфавит принят русский алфавит из 33 букв,
будет слово "аублзтмуае" (необходимо
сложить номера букв шифруемого слова и ключа, затем взять результат по модулю
33 (т.е. остаток от деления на 33) и сформировать шифрованное слово из букв с
получившимся кодом). Например, при шифровании и н ф о р м а ц и я + ц е л ь ц е л ь ц е получим и + ц, что соответствует 10 + 24 = 34
= 1 и букве а, н + е, что соответствует
15 + 6 = 21 и букве у, и т.д.). Какое
слово было зашифровано, если в результате получено слово "жцхяёй"?

Составьте программу, реализующую эпизод применения компьютера в книжном магазине. Компьютер запрашивает стоимость книг и сумму денег, внесенную покупате

лем. Если сдачи не требуется, печатает на экране «Спасибо». Если денег внесено больше, то печатает «Возьмите сдачу» и указывает сумму сдачи. Если денег недостаточно, то печатает об этом сообщение и указывает размер недостающей суммы.

на паскале

Читайте также

Помогите написать код решения в паскале.

Кощей Бессмертный зарыл клад на глубину 1 м. Этого ему показалось не
достаточно, он отрыл клад, углубил колодец до 2 м и снова зарыл. Этого ему
опять показалось мало, он отрыл клад,
углубил колодец до 3 м
и зарыл. Затем он проделал тоже, углубив
колодец до 4 м, потом до 5 м, 6 м и т.д. Известно, что колодец глубиной

помогите пожалуйста решить задачу по информатике!!!

в заповедник выпустили z зверей. за год количество особей увличивается на определенный процент. Сколько зврей будет через определенное время?
1. условие задачи
2. математическая модель
3. список переменных с их расшифровкой
4. блок- схема алгоритма
5. программный код



Вы находитесь на странице вопроса "Программный код решения уравнения x^2-cosx=0", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.