Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

пользователь вводит два числа если большее кратно меньшему то найдите их сумму в противном случае найдите их частное

5-9 класс

Nastenkalevka 22 февр. 2017 г., 7:26:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ирисска3
22 февр. 2017 г., 8:17:36 (7 лет назад)

var a,b:integer;

Begin

  read(a,b);

  if ((a>b) and (a mod b = 0))

    or ((b>a) and (b mod a = 0)) then writeln(a+b)

  else writeln(a-b);

End.

Ответить

Читайте также

введены два числа вывести их решение произведение если первое больше второго и разность в противном случае

ввели ц числа определите большее или меньшее 25-ти их сумма

Дан массив из N элементов(12 элементов), заданный случайным образом от -10 до 10. Вывести на экран этот массив. С клавиатуры вводятся два числа меньше N.

Вывести на экран часть массива входящих в диапазон, двух введенных чисел. Эти два числа будут индексами к тем числам, которые надо вывести.

. Составьте программу (полный текст программы) для решения следующей задачи. Введите с клавиатуры три числа: А, В, С. Если все они четные, то найдите и

выведите на экран их сумму. Если все они нечетные и A>B>C, то определите и выведите значения наибольшего и наименьшего из чисел. Иначе, выведите числа без изменения. Фрагмент программы: if (a mod 2 = 0) and (b mod 2 = 0) and (c mod 2 = 0) then begin S:=a+b+c; writeln('сумма равна ', S); end; if (a mod 2 <> 0) and (b mod 2 <> 0) and (c mod 2 <> 0) and (a>b) and (b>c) then begin writeln('наибольшее число ', A); writeln('наименьшее число ', C); end else writeln('a= ',a,' b= ', b, ' c= ',c);



Вы находитесь на странице вопроса "пользователь вводит два числа если большее кратно меньшему то найдите их сумму в противном случае найдите их частное", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.