Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОМОГИТЕ написать программу для суммирования четных элементов на нечетных позициях в одноименном массиве

5-9 класс

Supersergei196 22 июля 2014 г., 18:07:41 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nastyaantyfeeva
22 июля 2014 г., 18:48:03 (9 лет назад)

for i:=1 to n do 
begin 

+ 0 -
Megazhulidova
22 июля 2014 г., 20:25:37 (9 лет назад)

const
  n = 30;

var
  a: array[1..n] of integer;
  i, s: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  s := 0;
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i], ' ');
    if ((i mod 2) = 1) and ((a[i] mod 2) = 0) then s := s + a[i]
  end;
  Writeln(#13#10, 'Сумма найденных элементов ', s)
end.

Тестовое решение:
Исходный массив
49 -39 -17 6 24 38 20 50 6 -36 -4 -7 -31 41 -8 20 32 49 -48 -47 50 48 -41 -44 -26 -11 9 38 -24 -34
Сумма найденных элементов 22


Ответить

Читайте также

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.

составить на Паскале: 1) программу для вычисления суммы ряда S=1+ 1/2+1/3+1/4+..+1/N. Число N вводится с клавиатуры. 2) одноклеточная

амеба каждые 3 часа делиться на 2 клетки. Определить, сколько амеб будет через 3,6,9,12 и 24 часа.

3) дано натуральное числоо N и действительное число Х. Вычислить сумму ряда sin(x)+sin(2x)+sin(3x)+...+sin(Nx).

4) написать программу для вычисления n-ой степени числа А.

помогите, пожалуйста)

Написать программу для определения максимального числа из данных пяти чисел.

Пользователь вводит пять чисел. Программа выводит ответ: "Максимальное число ... ".
Написать программу в "КуМиРе"

1.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами до 50. Найти сумму всех четных элементов массива и их количество.

2.Дан массив целых чисел из 25 элементов. Заполнить его случайными числами от 0 до 50. Заменить все четные элементы на их квадраты, а нечетные удвоить.



Вы находитесь на странице вопроса "ПОМОГИТЕ написать программу для суммирования четных элементов на нечетных позициях в одноименном массиве", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.