Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

. Определить количество натуральных двузначных чисел, меньших 50, которые не делятся на 11. в делфи

10-11 класс

Sevost1986 05 марта 2014 г., 4:09:54 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Tatyana1812tn
05 марта 2014 г., 5:34:19 (10 лет назад)

var

  i, ans: byte;

 

begin

  ans := 0;                           // Обнуляем ответ.

  for i := 10 to 49 do          // Переменной i перебираем значения от 10 до 49, то есть все

                                             натуральные двузначные числа, меньшие  50-ти

    if i mod 11 <> 0 then   // Если текущее значение переменной не делится на 11, то…

      inc(ans);                      // Увеличиваем ответ

  writeln(ans);                   //Выводим окончательный ответ

end. 

 

Ответить

Другие вопросы из категории

Получите верные равенства, записанные в римской системе счисления.

1)
MXXV + XXXII =


2)
LI + LII =


3)
XLVIII + CCLXVIII =


4)
MD – CC =


5)
CMXCIX – CIX =


Pascal ABC.

Есть полоска из белых клеток. Двое ходят по
очереди. За ход разрешается покрасить в чёрный цвет одну белую клетку. Кто не может
сделать ход, проигрывает.

Читайте также

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.

№1 Определите количество пассажиров, которые могут поместиться на борт самолёта грузоподъемностью 8т(вес каждого пассажира вводится с клавиатуры).

№2 Начальный вклад в сберкассу составил А руб. Через сколько лет удастся накопить В руб. без учета дополнительных вкладов, если каждый год вклад увеличивается на 3%.

№3 Определите число суток с 1900 по 1999 года, если известно, что високосные годы - это те, у которых номер делится на 400 или те, у которых номер делится на 4, но не делится на 100.

1) Определите и выведите на экран количество чисел от 50 до 500, которые делятся на 11 и 13 одновременно. 2) Дан массив целых чисел, состоящий из 100

элементов. Заполнить его с клавиатуры. Найти:

а) удвоенную сумму положительных элементов;

б)вывести индексы тех элементов, значения которых больше значения предыдцщего элемента ( начиная со второго)



Вы находитесь на странице вопроса ". Определить количество натуральных двузначных чисел, меньших 50, которые не делятся на 11. в делфи", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.