Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу, в которой вывести все трехзначные числа, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)

10-11 класс

Uropb123 30 марта 2017 г., 0:42:46 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nasta999999999
30 марта 2017 г., 2:29:53 (7 лет назад)

var a,b,i,s:integer; readln(a); readln(b); for i=100 to 999 do  begin if (i mod 10)+(i div 100)+((i mod 100) div 10)=a then begin if i mod b = 0 then writeln(i); end; end; end.

Ответить

Другие вопросы из категории

Даны два массива чисел X = (x1,x2,...,xn) и У = (у1,у2,...,уn).

Найти массив Z, у которого каждый элемент zi равен
произведению хi*уi, и как будет выглядеть блок схема?

очеень нужно,пожалуйста помогите!

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и

until)////


ввести натуральное число и определить, какие цифры встречаются несколько раз (через repeat и until)///


ввести целое число и найти сумму его цифр (через while)


ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

последние аk =( 1,9x+ 7k)/k!

program sum;
const e = 0.001;
var x, a,summa : real;
k : integer;
function Factorial(n: word): LongInt;
begin
if n=0 then Factorial := 1 else Factorial := n*Factorial(n-1);
end;
begin
writeln('Введите x:');
readln(x);
summa:= 0;
k:=1;
a := 1.9*x+exp(k*ln(7));
while abs(a) > e do
begin
summa:=summa + a;
k := k + 1;
a := exp(1.9*x+exp(k*ln(7)))/Factorial(k);
end;
writeln('Сумма=', summa:5:2);
writeln('Количество слогаемых=', k-1);
end.
Где ошибка?

Написать функцию, которая возвращает символ строки с самой высокой частотой

встречаемости. Прототип функции char function_name (char *s). Проверить
работу функции на строке, введенной с клавиатуры. Реализовать вывод результата

Помогите с информатикой)

Какой объём видеопамяти необходим для хранения четырёх страниц изображения при условии, что разрешающая способность дисплея равна 640х480 точек, а используемых цветов-32?

Читайте также

Язык "Паскаль АВС" 1.Среди двухзначных чисел найти количество четных чисел. 2. Среди двухзначных чисел найдите те числа, у которых первая цифра четная.

3. Среди двухзначных чисел найдите те числа, которые кратны 3 и 4. 4. Среди трехзначных чисел найдите те, у которых все цифры равны. 5. Найдите среди трехзначных чисел симметричные числа. 6. Найдите среди четырехзначных чисел симметричные числа. 7. Найдите все трехзначные числа такие, что сумма цифр равна А, а само число делится на В. А и В вводятся с клавиатуры. 8. Найдите все трехзначные числа такие, которые при увеличении на 1 делятся на 2, при увеличении на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. 9. Найдите количество трехзначных чисел, сумма цифр которых равна А, а само число заканчивается на В, А и В вводятся с клавиатуры. 10. Найдите все трехзначные числа, у которых сумма крайних цифр равна сумме средних цифр, а само число делится на 6 и 27. 11.Найдите все трехзначные числа, которые при делении на 2 дают остаток 1, при делении на 3-остаток 2, при делении на 4-остаток 3, само число делится на5. 12. Найдите все четырехзначные числа, в которых есть две одинаковые цифры. 13. Найдите сумму всех чисел из промежутка от А до В, кратных 13 и 5, А и В вводятся с клавиатуры. 14. Найдите все симметричные четырехзначные числа. 15.Найдите все трехзначные числа, которые состоят из различных цифр, а их сумма равна А.

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и until)//// ввести натуральное

число и определить, какие цифры встречаются несколько раз (через repeat и until)///

ввести целое число и найти сумму его цифр (через while)

ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

всё через паскаль абс

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.

Помогите написать программу)))

Задано трехзначное число, определить:
1) сумму цифр этого числа;
2) произведение;
3) минимальную цифру;
4) максимальную цифру этого числа.



Вы находитесь на странице вопроса "Написать программу, в которой вывести все трехзначные числа, такие, что сумма цифр равна А, а само число делится на В (А и В вводятся с клавиатуры)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.