Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

На входе целое число, например 321. Получить число 321321

10-11 класс

Sonya116 31 марта 2017 г., 20:35:12 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gorsveta80
31 марта 2017 г., 22:26:03 (7 лет назад)

Именно число? Тогда полностью корректное решение не использующее костылей будет таким:
#include <iostream>
#include <cmath>
using namespace std;

int main() {
    int n;
    cin >> n;
    int tmp = n, count = 0;
    for (;tmp > 0; count++) tmp /= 10;
    n = n * pow(10, count) + n;
    cout << n;
    return 0;
}

+ 0 -
Sashamarakov
01 апр. 2017 г., 1:22:59 (7 лет назад)

cin>>a;
cout<<a<<a<<endl;

Ответить

Другие вопросы из категории

Даны два массива чисел X = (x1,x2,...,xn) и У = (у1,у2,...,уn).

Найти массив Z, у которого каждый элемент zi равен
произведению хi*уi, и как будет выглядеть блок схема?

очеень нужно,пожалуйста помогите!

4 задачи: ввести натуральное число и определить, верно ли, что сумма цифр равна 10 (через repeat и

until)////


ввести натуральное число и определить, какие цифры встречаются несколько раз (через repeat и until)///


ввести целое число и найти сумму его цифр (через while)


ввести целое число и определить , верно ли, что в его записи есть две одинаковые цифры(через while)

последние аk =( 1,9x+ 7k)/k!

program sum;
const e = 0.001;
var x, a,summa : real;
k : integer;
function Factorial(n: word): LongInt;
begin
if n=0 then Factorial := 1 else Factorial := n*Factorial(n-1);
end;
begin
writeln('Введите x:');
readln(x);
summa:= 0;
k:=1;
a := 1.9*x+exp(k*ln(7));
while abs(a) > e do
begin
summa:=summa + a;
k := k + 1;
a := exp(1.9*x+exp(k*ln(7)))/Factorial(k);
end;
writeln('Сумма=', summa:5:2);
writeln('Количество слогаемых=', k-1);
end.
Где ошибка?

Написать функцию, которая возвращает символ строки с самой высокой частотой

встречаемости. Прототип функции char function_name (char *s). Проверить
работу функции на строке, введенной с клавиатуры. Реализовать вывод результата

Читайте также

Напишите программу, которая в последовательности целых чисел определяет их количество и подсчитывает сумму положительных чётных чисел, не превосходящих

256. Программа получает на вход целые числа, количество введённых чисел неизвестно, последовательность чисел заканчивается числом 0 (0 — признак окончания ввода, не входит в последовательность). Количество чисел не превышает 1000. Введённые числа по модулю не превышают 30 000. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256.

По заданному числу n от 1 до 365 определите, на какое число какого месяца приходится день невисокосного года с номером n. Программа получает на вход

целое число n и должна вывести два числа: число месяца (от 1 до 31) и номер месяца (от 1 до 12), на которое приходится данный день.

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.

Изначально, задача была такая: На вход программы подается натуральное число. Требуется написать программу, которая определяет составное или простое число

на входе и выводит сумму его цифр.

Я написал первую часть программы (без вывода суммы цифр) :

program sg3;

uses crt;

var i,a,k: integer;

begin

clrscr;

write('Введите число: ');

readln(a);

k:=0;

for i:=2 to a div 2 do

if a mod i =0 then k:=k+1;

if k=0 then write('Простое')

else writeln('Составное');

readln;

end.

Допишите пожалуйста код, который бы выводил сумму цифр,Паскаль

Дана строка , в которой содержится осмысленное текстовое сообщение. Слова сообщения разделяются В заданном формате дд- целое число из диапазона от 1 до

31, мм - целое число из диапазона от 1 до 12, а гг - целое число из диапазона от 1 до 2020 (если какая-то часть формата нарушена, то данная подстрока в качестве даты не рассматривается.) Заменить каждую дату сообщения на дату следующего дня. Написать программу на Паскале. Сроооооооооооооочнооо. Пооожалуйста.....

10-11 класс информатика ответов нет


Вы находитесь на странице вопроса "На входе целое число, например 321. Получить число 321321", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.