Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

В каждой строке двумерной матрицы (n, m), состоящей их произвольных чисел, вычислить количество, сумму и среднее арифметическое отрицательных элементов

10-11 класс

Chopa2003 15 июля 2013 г., 10:38:18 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kamilyaakhmato
15 июля 2013 г., 12:21:47 (10 лет назад)

program asd;
Const n=4; 
   m=4;
var A:array[1..n,1..m] of integer;
i,j,k,s:integer;
 sr:real;
BEGIN 
For i:=1 to n do 
  begin 
 for j:=1 to m do  
   begin   
  A[i,j]:=5-Random(15);
     Write(A[i,j]:4); 
 end;
 Writeln();
 end;
 For i:=1 to n do 
  begin 
s:=0; k:=0; 
  for j:=1 to m do  
  begin     
      If A[i,j]<0 then 
      begin   
 s:=s+A[i,j];   
 inc(k);   
 sr:=s/k;   
  end;  
   end;   
 Writeln('Строка: ',i,'; Сумма: ',s,'; Количество: ',k,'; Ср. ариф.: ',sr:2:2); 
   end;     
   END.

Ответить

Другие вопросы из категории

найти x, если 52^10=x^8
Разработать программу для решения задачи, ввод данных организовать через рабочий лист MS Excel (Написать код)

Из данного массива А трехзначных чисел записать в массив В элементы, содержащие цифру 5.
Исходные данные на картинке. Заранее Спасибо!

Читайте также

Составить программу в PASCAL.

Ввести размерность матрицы и значения ее элементов.
Определить максимальный и минимальный элемент. Переставить их местами.
Найти среднее арифметическое отрицательных элементов в i-ой строке.

Составить функцию определения факта нахождения в одномерной матрице хоть одного нуля, состоящей из целых чисел и количеством элементов k. применить данную

функцию для нахождения номеров строк, произвольной матрицы, не содержащей нулей. Составить на языке паскаль.

дано массивы A(N1,N1),B(N2,N2),C(N3,N3). найти в каждой строке исходного массива наименьший элемент и переставить его с элементом стоящим на главной

диагонали. нахождение в каждой строке массива наименьшего элемента и его перестановку с элементом стоящим на главной диагонали оформить в виде подпрограммы

ПАСКАЛЬ АБС! СРОЧНО! ПОМОГИТЕ ПОЖАЛУЙСТА!

1. напишите программу формирования массива размером 5*5 с помощью датчика случайных чисел. Замените в нем нечетные значения элементов максимальным. Выведите на экран исходный и измененный массивы.
2. Составьте программу формирования и вывода на печать одномерного массива, состоящего из максимальных элементов строк двумерного массива, заданного с помомщью датчика случайных чисел

1)напишите программу формирования массива размеров 5 х 5 с помощью датчика случайных чисел.замените в нем все четные значения элементов суммой

индексов элементов главной диагонали.Выведите на экран исходный и измененный массивы (программа на языке Паскаля)
2)Составьте программу формирования и вывода на экран одномерного массива, состоящего из удвоенных минимальных элементов строк двумерного массива, заданного с помощью датчика случайных чисел



Вы находитесь на странице вопроса "В каждой строке двумерной матрицы (n, m), состоящей их произвольных чисел, вычислить количество, сумму и среднее арифметическое отрицательных элементов", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.