Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Скласти програму з інформатики)

10-11 класс

Padfoot 21 апр. 2013 г., 6:58:16 (11 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Sergovoy
21 апр. 2013 г., 9:54:28 (11 лет назад)

var
  simple: array[1..10000] of integer;
  i, j, a, b, simple_n, s: integer;
  is_simple: boolean;

begin
  read(a, b);
 
  for i := 2 to b do begin
    is_simple := true;
    for j := 1 to simple_n do
      is_simple := is_simple and (i mod simple[j] <> 0);
    if is_simple then begin
      simple_n := simple_n + 1;
      simple[simple_n] := i;
      writeln(i);
      if i >= a then s := s + i;
    end;
  end;
 
  writeln(s);
end.

+ 0 -
Darq
21 апр. 2013 г., 10:35:26 (11 лет назад)

любую?

+ 0 -
Жанна1996000
21 апр. 2013 г., 11:30:27 (11 лет назад)

да

Ответить

Другие вопросы из категории

1. найти среднее значение элементов двумерного массива A[1..5,1..5] Массив заполнить натуральными числами от 1 до 25. вывести на экран массив виде таблицы

и среднее значение.
2. В одномерном массиве произвольных чисел вычислить среднее арифметическое значение квадратов положительных элементов.
3. напечатать числа следующим образом
14 10.4
15 11.4
...
27 25.4
Помогите пожалуйста, скоро зачет, надо все сдать

Даны 4 числа, они записаны с использованием различных систем счисления. Укажите среди этих чисел то, в двоичной записи которого содержится ровно 6

единиц. Если таких чисел несколько, укажите наибольшее из них. 1) 6310 * 410 2) F816 + 110 3) 3338 4) 111001112

Читайте также

Помогите пожалуйста. Нужно решить в паскале.

Дано масив А[1..n]. Скласти програму підрахунку суми всіх елементів, що знаходяться між елементами А[1] і А[n].



Вы находитесь на странице вопроса "Скласти програму з інформатики)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.