Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Помогите пожалуйста написать программу на паскале. Даны натуральное число N и действительное число X.Вычислить:tg X+tg tg X+tg tg tg X+...+tg tg...tg X.

10-11 класс

впропопмрь 30 окт. 2014 г., 15:03:44 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Marxa000
30 окт. 2014 г., 17:57:38 (9 лет назад)

var
n, i: integer;
x, ans, s: real;
begin
readln(n, x);
ans := tg(x);
s = ans;
for i := 2 to n do
begin
ans := tg(ans);
s := s + ans;
end;
writeln(s);
end.

+ 0 -
Kiryushapavlov
30 окт. 2014 г., 20:43:41 (9 лет назад)

"tg X+tg tg X+tg tg tg X+" может вы имели ввиду tg x + tg x + tg x....? просто в паскале невозможно прибавить просто тангенс без переменной

+ 0 -
ElinaM
30 окт. 2014 г., 23:26:13 (9 лет назад)

нет,том получается тангенс числа,потом тангенс тангенса числа и т.д.

+ 0 -
Marysya7769
31 окт. 2014 г., 1:28:31 (9 лет назад)

ок

+ 0 -
Cvest98ru
31 окт. 2014 г., 2:29:52 (9 лет назад)

тангенс тангенса не может быть, при x = 3 - просто тангенс = -0.142546543074278, при tg(tg(x)) - тоже самое число

+ 0 -
Dragogogo
31 окт. 2014 г., 5:09:58 (9 лет назад)

а хотя нет, ошибся

Ответить

Другие вопросы из категории

Помогите, пожалуйста.
помогите решить! срочно!
Один ученик написал: " У меня 100 конфет. Я поровну разделил их между мной и моими друзьями. каждому досталось по 11 конфет и одна осталась лишней.

Какую систему счисления использовал ученик и сколько у него было конфет в десятичной системе счисления?

На отрезке [0; 6.4] (задано в радианах) с шагом 0.4

построить графики функций sin(x) и cos(x).

Читайте также

Помогите, пожалуйста написать программу на паскаль

Дано натуральное число. Вычислить количество цифр, являющихся степенями тройки (1,3,9).

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!



Вы находитесь на странице вопроса "Помогите пожалуйста написать программу на паскале. Даны натуральное число N и действительное число X.Вычислить:tg X+tg tg X+tg tg tg X+...+tg tg...tg X.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.