Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Дана матрица размерностью N*M. Найти среднее

10-11 класс

арифметическое простых чисел матрицы.

Mihalin2 24 авг. 2015 г., 14:19:27 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
1313a
24 авг. 2015 г., 17:08:07 (8 лет назад)

В турбо паскале, к сожалению, нет динамических массивов, по крайней мере, я в описаниях ничего не нашел, поэтому придется заранее задать N и M.
Пусть будет N = 10, M = 20. Для чисел меньше миллиона функция Prost работает за вполне приемлемое время.

PROGRAM SredProst;
var A: array [1..10, 1..20] of integer;
var i, k, p: integer, S: real;
FUNCTION Prost(n: integer): integer
var i: integer
BEGIN
Prost:=1;
{esli n delitsia na kakoe-to chislo ot 2 do kornya iz n, to n sostavnoe}
for i:=2 to sqrt(n) do if (n mod i = 0) then Prost:=0;
END;

BEGIN
uses crt; clrscr;
{Vvodim nachalniy massiv}
for i:=1 to 10 do
begin
for k:=1 to 20 do read (A[i,k]);
end;
S:=0; p:=0;
{Ischem prostye chisla, summiruem ih v S i schitaem kol-vo v p}
for i:=1 to 10 do
begin
for k:=1 to 20 do
begin
{Prost - eto funkcia poiska, prostoe chislo ili net}
if (Prost(A[i,k]) = 1) then
begin
S:=S+A[i,k];
p:=p+1;
end;
end;
end;
{Srednee - eto summa chisel, delennaya na ih kol-vo}
S:=S/p;
writeln ('Srednee vseh prostyh chisel ', S);
END.

+ 0 -
Denissarmin
24 авг. 2015 г., 18:35:12 (8 лет назад)

Комментарий удален

+ 0 -
ИннаРич
24 авг. 2015 г., 20:52:51 (8 лет назад)

К сожалению, больше никаких условий у задачи нет....

+ 0 -
Sonechka1406
24 авг. 2015 г., 21:39:20 (8 лет назад)

Комментарий удален

+ 0 -
Ayka77732
24 авг. 2015 г., 22:22:54 (8 лет назад)

Вся проблема в том, что я совершенно не понимаю турбо паскаль, в котором это надо решить, и не имею представления как это сделать... :(

+ 0 -
Fafafafa2
25 авг. 2015 г., 1:22:07 (8 лет назад)

Комментарий удален

Ответить

Другие вопросы из категории

1 задача :Массив Z(20) заполнить целыми случайными числами в диапазоне от -20 до 20. Вычислить CP- среднее арифметическое положительных элементов и CN-

среднее арифметическое отрицательных элементов массива Z. Вычислить P как сумму CP+CN, если CP>CN, или как произведение CP*CN, если CP
2 задача: Матрицу А(15, 4) заполнить целыми случайными числами в диапазоне от 1 до 51. Составить матрицу В(?, 4) из таких строк массива А, чтобы для каждого элемента A(I,J) данной строки I выполнялось условие 10<А(1,J) <40 . Матрицу В заполнить плотно. Если таких строк не окажется, необходимо вывести соответствующее сообщение. Вывести А и B Кто решит буду благодарен, нужно очень.

Некоторый алгоритм из одного числа получает новое число следующим образом. Сначала записывается исходное число, а затем к немц приписываются цифры

исходного числа в обратном порядке, а в конце числа дописываетсястолько единиц сколько нечетных цифр в исходном числе. Получившееся число является результатом работы алгоритма. Например если исходное число было 325, то результатом работы алгоритма будет число 32552311.

Дано число 25. Сколько единиц будет содержаться в итоговом числе, если к исходному числу применить алгоритм трижды (т.е применить алгоритм к данному числу, а затем к результату вновь применить алгоритм и т.д)?

В программе Microsoft Ехсеl: Постройте стандартную диаграмму типа «Лепестковая»,

вид «С маркерами» для следующих функций: Y=x⁴+2x+5, Y=x²-x+1

1FA^16 перевести в 10

Читайте также

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

Добрый день. Помогите пожалуйста решить две задачи... №1 Дан массив из 25 элементов,найти сумму 4-х наибольших и 4-х наименьших э

лементов. Результат распечатать в виде:

Сумма наибольших=

Сумма наименьших=

№2

Даны два массива по 30 элементов. Найти среднее арифмитическое для элементов 1-го массива,номера которых больше номера минимального элемента 2-го массива

Заранее спасибо

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Дана матрица размерностью n*m.

найти в каждой строке max и min элемент



Вы находитесь на странице вопроса "Дана матрица размерностью N*M. Найти среднее", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.