Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дана матрица размерностью n*m.

10-11 класс

найти в каждой строке max и min элемент

Wry8937 01 авг. 2013 г., 19:44:04 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Пвлш
01 авг. 2013 г., 21:58:31 (10 лет назад)

const
  m1 = 20;
  n1 = 20;

var
  x: array[1..m1, 1..n1] of integer;
  i, j, m, n, mx, mn: integer;

begin
  Write('Введите через пробел число строк и столбцов матрицы: ');
  Readln(m, n);
  Randomize;
  writeln(#13#10, 'Исходная матрица');
  for i := 1 to m do
  begin
    for j := 1 to n do
    begin
      x[i, j] := Random(100) - 50;
      Write(x[i, j]:5)
    end;
    Writeln
  end;
  for i := 1 to m do
  begin
    mx := x[i, 1]; mn := mx;
    for j := 2 to n do
      if mx < x[i, j] then mx := x[i, j]
      else if mn > x[i, j] then mn := x[i, j];
    Writeln('В строке ', i, ' мin=', mn, ', max=', mx)
  end
end.

Тестовое решение:

Введите через пробел число строк и столбцов матрицы: 5 8

Исходная матрица
   14   35    4   16   44  -14   47   36
  -23  -40   16   43   40   48   21   46
   23   30  -18   25  -43   -5   -3   37
   24  -26    9  -37   36   23  -33   36
   30   46   17  -18  -34  -35   36   28
В строке 1 мin=-14, max=47
В строке 2 мin=-40, max=48
В строке 3 мin=-43, max=37
В строке 4 мin=-37, max=36
В строке 5 мin=-35, max=46


Ответить

Другие вопросы из категории

Паскаль

Дан массив размера n и целые числа К и 1 (1? K? 1?n) . Найти сумму элементов массива с номерами от К до 1 включительно.

помогите решить пліз хотяби несколько

]Варіант-1
Дана послідовність слів. Визначити кількість букв “А” і “Б” в ній. Якщо таких букв немає, то вивести повідомлення.

Варіант-2
Скласти програму, яка підраховує число тих слів у реченні із И букв, в яких на другій позиції знаходиться задана буква. Слова розділенні пропусками. Якщо таких слів немає, то видається повідомлення .

Варіант-3
Скласти програму, яка із заданого слова вилучає всі букви “А”.

Варіант-4
Скласти програму, яка виводить на екран всі символи.

Варіант-5
Скласти програму, яка визначає скільки цифр у заданому числі і знаходить їх добуток.

Варіант-6
Скласти програму, яка підраховує кількість букв у введеному реченні. Словом м/б розділенні пропусками, або комами.

Варіант-7
Написати програму, яка перевіряє чи стоїть перед “що” кома.

Варіант-8
Написати програму, яка перевіряє чи поставили в кінці речення, що вводиться крапка.

Варіант-9
Скласти програма, яка виводить слово ззаду на перед.

Варіант-10
Дана послідовність слів. Перевірити чи є в ній задане слово.

Варіант-11
Задати речення. Програма повинна виводити на екран всі символи, що зустрічаються до першого знака “-”. Якщо його немає, то виводиться повідомлення.

Варіант-12
Вивести слово задом наперед.

Варіант-13
У заданому реченні знайти найдовше (найменше) слово.

Варіант-14
Скласти програму, яка із слова “інтеграл” утворює слово “гантелі”, “тигр”.



Варіант-15
Знайти найменше із слів, що записані в реченні.

Варіант-16
Написати програму, яка по назві дня неділі визначає номер цього дня 1...,2,...,7.

Варіант-17
Дана послідовність слів підрахувати скільки слів закінчуються на “А”.

Варіант-18
Скласти програму, яка підраховує скільки раз в послідовність слів зустрічається буквосполучення “сок”.

Варіант-19
Написати програму, яка виводить на екран коди всіх букв.

Варіант-20
Скласти програму, яка перевіряє чи поставили вкінці речення “крапку”.

Варіант-21
Програма підраховує число тих слів в, яких на другій позиції стоїть буква “А”.

Варіант-22
Скласти програму, яка виводить на екран всі символи після знаків “-“.

Варіант-23
Написати програму, яка визначає, чи являється введене слово “перевертишем” (напр. “ПОТОП”, “КАЗАК”).

Варіант-25
Скласти програму, яка вилучає із заданого слова всі букви “А”.

Решить на C#, используя циклы. Составить программу для вычисления и вывода n первых чисел Фибоначчи. Числа Фибоначчи получаются с помощь

ю следующих рекуррентных соотношений f_{1}=f_{2}=1, f_{n}=f_{n-1}+f_{n-2}, n\geq3, где f_{n} - целое. Отследить корретность ввода исходных данных.

Читайте также

Дана матрица размерностью nxn найти

Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы. Найти квадрат разности среди арифметических значений элементов матрицы ,находящихся ниже и выше главной диагонали

1)Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного.

2)дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов. Использовать три процедуры (заполнение, смена, вывод).

Написать программу для паскаля. Дана квадратная матрица

порядка n(n=5).
Если в данной матрице a нет отрицательных элементов,
то транспонировать её, иначе выдать сообщение.

Помогите пожалуйста!)

Задание 3.
Дана квадратная матрица размерностью N. Подсчитать количество отрицательных элементов по строкам. ВВЕДИТЕ РАЗМЕРНОСТЬ МАТРИЦЫ N:-
->5
Через пробел введите N*N элементов массива:
--> 10 3 2 6 8
3 -2 7 -1 4
4 5 -10 9 -12
5 0 2 4 5
6 3 -3 -5 2
Количество: 0,2,2,0,2



Вы находитесь на странице вопроса "Дана матрица размерностью n*m.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.