Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

ОЧЕНЬ СРОЧНО НУЖНО написать программу на С++. Идет n-я секунда суток. Определить, сколько полных часов и полных минут прошло до этого момента. +

10-11 класс

Отформатировать исходный код программы. + Определить ограничения на задаваемые пользователем значения и не допустить ввода неверных щначений

Igor1203 09 нояб. 2015 г., 9:00:15 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Ира7Ник
09 нояб. 2015 г., 9:58:45 (8 лет назад)

#include<iostream.h>


 using namespace std;


int main() 

{

    int n=0;

    cout<<"Введите секунды."<<endl;

    cin>>n;

    if(n>60*60*24)

    {

     cout<<"Неправельный ввод: в сутках меньше, чем "<<n<<" секунд"<<endl;

    }

    else

    {

     cout<<"Прошло полных часов: "<<(n-n%3600)/3600<<endl;

     cout<<"Прошло полных минут: "<<(n-n%60)/60<<endl;

    }

    system("pause");
    return 0;   
}

 

/*

 В некоторых компиляторах нельзя выводить русский текст таким образом, нужно выводить английский текст или второй вариант программы:

 

#include<iostream.h>

#include<windows.h>


 using namespace std;

 

char bufRus[256];
 
char* Rus(const char* text)

{
      CharToOem(text, bufRus);
      return bufRus;
}


int main() 

{

    int n=0;

    cout<<Rus("Введите секунды.")<<endl;

    cin>>n;

    if(n>60*60*24)

    {

     cout<<Rus("Неправельный ввод: в сутках меньше, чем ")<<n<<Rus(" секунд")<<endl;

    }

    else

    {

     cout<<Rus("Прошло полных часов: ")<<(n-n%3600)/3600<<endl;

     cout<<Rus("Прошло полных минут: ")<<(n-n%60)/60<<endl;

    }

    system("pause");
    return 0;   
}

 

 P.S сорри, что не срочно, увидел только сейчас.

*/

Ответить

Другие вопросы из категории

Напишите программу в паскале абс.

С клавиатуры вводятся целые числа a, b и c. Вычислите значение
следующего выражения

где

Система КуМир нужно:

Составить цикл (для, пока и кц при).

1) Составьте программу, которая вычисляет среднее
арифметическое положительных и четных чисел из N введенных. Значение N вводится с клавиатуры.

1+2+3+4+5/10-7=5 раскодировать
Дана матрица размерностью N*M. Найти среднее

арифметическое простых чисел матрицы.

Читайте также

написать программу на Assembler

добрый вечер, всем. помогите, пожалуйста, написать программу на Ассемблере.

задание:
Создать программу на языке Ассемблер, что позволяет организовать вычисления над элементами массивов

Объединить два массива 8-битных целых чисел со знаком. Сначала элементы второго затем первого.

заранее огромное спасибо всем!

Помогите написать программу по Информатике! Найти произведение двузначных нечетных чисел, кратных

13.

Нужно написать программу на цикле с предусловием, на Паскале.

Написать программу, которая вводит с клавиатуры одномерный массив из n целых чисел, после чего выводит нулевые элементы с их индексами (их можно и не

оказаться)

нужно написать программу на c++
Используя обращения 1) по индексу и 2) по указателю.

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Помогите написать программу на C#

Дано натуральное число n. Написать программу вычисляющую сумму



Вы находитесь на странице вопроса "ОЧЕНЬ СРОЧНО НУЖНО написать программу на С++. Идет n-я секунда суток. Определить, сколько полных часов и полных минут прошло до этого момента. +", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.