Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Пожалуйста кто нибудь помоги, кто в ладах с Турбо паскалем Надо написать программу для следующих формул F=Sqrt(X+3SqrtX)/x

10-11 класс

Z=X3/y где y=sin(nx)+0.5

Yaldiman95 18 июня 2016 г., 21:34:43 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
руся2511
18 июня 2016 г., 23:04:33 (7 лет назад)

program gt;
var x,y,f,z:real;
begin
read(x);
y:=sin(x*pi/180)+0.5;
z:=x*3/y;
f:=sqrt(x+3*sqrt(X))/x;
writeln(f:1:8,' ',z:1:8);
end.

+ 0 -
эслин
19 июня 2016 г., 0:15:08 (7 лет назад)

Во второй формуле х в кубе или умножается на 3 ?

Ответить

Другие вопросы из категории

Даны две переменные вещественного типа: A, B. Перераспределить значе-

ния данных переменных так, чтобы в A оказалось меньшее из значений,
а в B — большее. Вывести новые значения переменных A и B.

Читайте также

Помогите надо написать программу в паскале. 1)координаты двух различных полей шахматной доски x1, y1,x2, y2 (целые числа, лежащие в диапазоне 1–8).

Проверить истинность высказывания: «Ладья за один ход может перейти с одного поля на другое». 2) Дано трехзначное число. Проверить истинность высказывания: «Все цифры данного числа различны». 3)Даны две переменные целого типа: A и B. Если их значения не равны, то присвоить каждой переменной сумму этих значений, а если равны, то присвоить переменным нулевые значения. Вывести новые значения переменных A и B.

Народ, помогите, надо написать программу. Язык - на ваше усмотрение. Заранее спасибо, если кто поможет)

Даю чёткое ТЗ:
Шаг 1: У нас есть поле, в котором необходимо указать количество возможных событий (лучше это поле подписать рядом), после ввода туда нужного числа переходим к шагу 2.
Шаг 2: Далее идут поля под события и их процентную вероятность(тоже можно подписать рядом знаком"%"), то биш одно большое и одно маленькое поле на каждую строчку. Количество занятых строчек зависит от количества событий, введенных нами в шаге 1. Теперь вводим в большие поля названия событий (допустим: "дождь", "солнце", "ветер"), а в малые поля вводим их процентную вероятность (допустим "15", "73", "12"). Затем нажимаем кнопку снизу "результат" и под этой кнопкой появится выпавшее событие. При повторном нажатии данной кнопки, ситуация повторяется и нам снова выпадает какое-то событие.

Пример 1:
Количество событий: 3
ОК
Солнечно: 60 %
Ветренно: 25 %
Дождливо: 15 %
Результат
(тут будет написан результат)

Пример 2:
Количество событий: 2
ОК
Попадание: 60 %
Промах: 40%
Результат
(тут будет написан результат)



Вы находитесь на странице вопроса "Пожалуйста кто нибудь помоги, кто в ладах с Турбо паскалем Надо написать программу для следующих формул F=Sqrt(X+3SqrtX)/x", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.