Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Даны две переменные вещественного типа: A,B. Перераспределить значения данных переменных так, чтобы в A оказалось меньшее из значений

10-11 класс

Maria8888 28 июня 2016 г., 11:49:08 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Gerashenkp
28 июня 2016 г., 13:05:48 (7 лет назад)

var  
a, b, p: real;
begin 
write('Введите значения A и B через пробел: '); 
readln(a,b); 
if a > b then   
begin   
p:=a;   
a:=b;   
b:=p;   
end; 
writeln('A = ', a, '; B = ', b);
end.

Ответить

Другие вопросы из категории

Если число меньше делимого равно этому числу, то это число называется чудом.Опредите, что данное число N является чудо цифрой. Формат входных

данных.

На первой доржка входного файла дане одна целая цифра N (1‹=N‹=1000000 )

Формат выходных данных

Если цифра является чудом , ответьте "да" или "нет"

Дан файл содержащий текст (не менее 3 строк) сколько слов в тексте?

(программирование)

Читайте также

Задание 3. Решить задачи: 1) Задайте в виде оператора присваивания следующие действия: a) переменной вещественного типа

х присвоить значение, равное полусумме значений а и b;

b) удвоить значение переменной х;

c) переменной целого типа х присвоить значение на 1 меньшее исходного;

d) сменить знак у переменной х на противоположный.

программа на C++ в визуальном режиме (есть несколько вариантов кода программы)

доброй ночи, уважаемые программисты и успевающие в учебе студенты. помогите, пожалуйста, написать программу на C++ (в визуальной вкладке).

ВОТ ЗАДАНИЕ:
дано три переменные вещественного типа. если их значения упорядочены по возрастанию или убыванию, то удвоить их; иначе заменить значение каждой переменной на противоположное. вывести значения переменных.


я прикрепила несколько тестовых файлов (блокнот) в которых есть несколько вариантов решение этого задание (то есть коды программ), а вы скажите какой из них лучше всего подходит, а также скажите какие компоненты нужно кинуть на форму-дизайн (то есть какие кнопки, и что на них писать). в этих 3 файлов есть написанный код программы, нужно написать: на какие кнопки что писать и какой вариант решение больше подходит.

заранее огромное спасибо всем за помощь!!!

Что такое подкачка данных в иерархической модели памяти?

(укажите несколько правильных ответов)


1) перемещение данных на самый высокии уровень

2) перемещение данных на самый низкии уровень

3) перемещение данных с более высоко уровня на более низкий

4) перемещение данных с более низкого уровня на более высокии

5) удаление данных с физического носителя

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)



Вы находитесь на странице вопроса "Даны две переменные вещественного типа: A,B. Перераспределить значения данных переменных так, чтобы в A оказалось меньшее из значений", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.