Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу Паскаль тремя способами ( с предусловием, постусловием, со счетчиком)

5-9 класс

Срочноооо

Mvladoss 18 февр. 2014 г., 21:50:33 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
вянковская
18 февр. 2014 г., 23:18:11 (10 лет назад)

1
var 
i: byte := 1; 
sum: integer := 0;
begin 
//Предусловие 
writeln('*** Цикл с предусловием ***'); 
while i <= 100 do 
begin   
sum := sum + i;   
inc(i); 
end; 
writeln('Сумма = ', sum:5); 
//Постусловие 
sum := 0; i := 1; 
writeln('*** Цикл с постусловием ***'); 
repeat   
sum := sum + i;   
inc(i); 
until i > 100; 
writeln('Сумма = ', sum:5); 
//Счетчик 
sum := 0; 
writeln('*** Счетчик ***'); 
for i := 1 to 100 do sum := sum + i; 
writeln('Сумма = ', sum:5);
end.

2

Ответить

Другие вопросы из категории

заполните таблицу
1.Пользователь работал с каталогом. D:\ ДОКУМЕНТЫ\ФОТО\2011\ВЕСНА. Сначала он поднялся на 3 уровня вверх, потом спустился в каталог ЭКЗАМЕН и после этого с

пустился в каталог ИНФОРМАТИКА. Укажите полный путь для того каталога, в котором оказался пользователь. ( запишите номер правильного ответа):
1) D:\ ДОКУМЕНТЫ \ФОТО \ИНФОРМАТИКА
2) D:\ ДОКУМЕНТЫ \ИНФОРМАТИКА \ЭКЗАМЕН
3)D:\ ДОКУМЕНТЫ \ЭКЗАМЕН \ИНФОРМАТИКА
4)D:\ ДОКУМЕНТЫ \ФОТО \2011 \ВЕСНА \ЭКЗАМЕН \ИНФОРМАТИКА


Вычислить информационный объем текстового документа в Мбайт ( с точностью до сотых ) и узнать сколько дискет 3,5 дюйма объемом 1,44Мбайт понадобися дя

переноса этого документа
Книга рекордов Петербурга - 235 страниц , 60 символов в строве , 48 строк на странице

Читайте также

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль

Паскаль ABC 1.Написать программу рисующую вертикальную цепочку из 7 кругов 2.Написать программу рисующую цепочку из 5 кругов

расположденных по диагонали

3.Написать программу рисующую горизонтальную цепочку из 12 кругов,каждый круг должен на половину закрывать предыдущий

Помогите,а то сижу с паскалем уже час с лишним и все никак не получается..

Заранее спасибо)

Написать программу, вычисляющую квадрат суммы двух введенных чисел.

(написать на языке программы паскаль, и если кто забыл, то квадрат суммы это - квадрат первого числа плюс удвоенное произведение первого на второе плюс квадрат второго числа )

Паскаль абс 2 задачи 1)Написать программу выводящую на экран последовательность чисел от 1 до 10 через пробел в строчку.

2)Написать программу которая бы выводила на экран произведение нечетных чисел от 10 до 20.

Помогите написать программу для Паскаля.

1. Написать программу нахождения произведения n чисел.



Вы находитесь на странице вопроса "Написать программу Паскаль тремя способами ( с предусловием, постусловием, со счетчиком)", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.