Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

Нужна помощь. Чему будет равняться k после выполнения программы

5-9 класс

Var m, k : integer;
begin
m:=0; k:=1;
while (m<5) do m:=m+1; k:=k+m;
writeln (k)
end.

Nbs1996 18 июня 2013 г., 0:32:28 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Avroramino
18 июня 2013 г., 2:08:39 (10 лет назад)

Вот ответ :K:=16 ( на языке Паскаль " к присвоить 16")

+ 0 -
Exemanyak02
18 июня 2013 г., 3:32:05 (10 лет назад)

По скольку в программе нет бегина после while (m<5) do, выполнится 5 раз м:=м+1, получится м=5, к=к+м, где к=1, м=5, а значит к=6, Нам выведется число 6.

Ответить

Другие вопросы из категории

ХЭЭЭЭЛП.Я ЩЕДРАЯ НА БАЛЛЫ :З

ПЕРВОЕ ПРЕДЛОЖЕНИЕ КАЖДОГО АБЗАЦА СДЕЛАТЬ В СТИЛЕ ЗАГОЛОВОК 1 ,ВТОРОЕ В СТИЛЕ ЗАГОЛОВОК 2

В торговом центре этажи нумеруются так: …, –3, –2, –1, 1, 2, 3, … (то есть нет нулевогоэтажа). Вася спустился на лифте с этажа с номером A на B этажей, а

затем поднялся на лифтена C этажей. Определите, на каком этаже он оказался.Программа получает на вход три целых числа: в первой строке записано число A, вовторой — B, в третьей — С. Число A не равно нулю и не превосходит по модулю 100, числа Bи С — положительные и не превосходят 100. Программа должна вывести одно целое число — номер этажа, на котором оказался Вася

помогите пож-ста 92 задачу

Читайте также

Помогите, пожалуйста, очень срочно

1. Чему будет равняться x после выполнения фрагмента программы:
x:=0;
repeat
x:=x+8
until x>=21.

2. Дано описание массива
var mas: array [-22;0] of integer;
Сколько элементов содержит данный массив?

3.Определите, что делает следующая программа, и какой результат она выдаст на заданном массиве (1,4,0,-1,-4)
Program n1
const n=5
var a: array [1...n] of integer;
i,b: integer;
begin
b:=a[1];
for i:=2 to n do
if a[i] writeln (b);
end.

4. Допустим, имеется одномерный массив, содержащий от 0 до 49 включительно. Требуется исключить из него все элементы, значения которых меньше 15.

Задание 1. Чему равен F(x) после выполнения следующих операторов? для x=4; 5; 3; 2; if x>=3

then if x<5 then F:=0

else F:=x*x

else F:=4+x

Чему равен R после выполнения следующих операторов?

R:= -10; 0; 5

if R<0 then R:=R*R;

if R=0 then R:=R+10;

if R>0 then R:=R-100;

Изменится ли строка ST, над которой произведут операцию COPY? Почему?

Чему будет равняться k после операции k:=length(‘мышь и клавиатура’)?

Чему будет равняться переменная tx после операции tx:=‘лесник’; delete(tx,4,3)?

Чему будет равняться переменная k после операции tx:=‘баобаб’; k:=pos(‘ба’,tx)?

Дополнить программу недостающими командами

Подсчитать количество букв “а” в тексте (русских и латинских; прописных и заглавных).

program zadacha1;

var t:string;

b:string[1];

n,k,i:integer;

Begin

writeln('Введите текст');

…………………………;

n:=length(t);

k:=0;

for i:=1 to n do

begin

b:=copy(t,i,1);

if ……………………………then k:=k+1;

end;

writeln('k=',k);

End.

1.Какое значение переменной S будет напечатано после выполнения фрагмента программы,записанной на языке программирования TURBO PASCAL:A:=2В: = 3;

if A>B then S: = A+B;
writeln (S);
Варианты ответов:1)5 ;2)6; 3)7; 4)8

2. Какое значение переменной S будет напечатано после выполнения фрагмента программы, записанной на языке программирования PASCAL:
S: =1;
N: =1;
while N<=3 do
begin
S: = S*N;
N: = N+1;
end;
writeln(S);
Варианты ответов: 1)2 ; 2)1; 3)0; 4)4

Сколько раз будет выполняться цикл

for i:=7 to 12 do...;
Чему будет равна переменная s после выполнения фрагмента программы
s:=40;
for i:=15 to 19 do
s:=s+1
Дан шаблон цикла
forx:=M downto N do begin...end;
Чему равен шаг цикла?
Помогите пожалуйста



Вы находитесь на странице вопроса "Нужна помощь. Чему будет равняться k после выполнения программы", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.