Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

1) числа 140

5-9 класс

53
104 перевести в десятичную и восьмеричную систему
2) 2 в 15 степени Бит - перевести в кбайт
2 в 23 степени -перевести в Мбайт
ПОМОГИТЕ! ОЧЕНЬ БУДУ БЛАГОДАРНА!!!

Super456 19 янв. 2014 г., 19:41:15 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
VungTau1215
19 янв. 2014 г., 21:34:05 (10 лет назад)

1) 140_{16} = 1 * 16^2 + 4 * 16 ^1 + 0 * 10^0 = 256 + 64 + 0 = 320_{10}

 

запише каждую цифру шестнадцатиричного числа в виде 4 разрядного двоичного числа и потом сгрупируем по 3 разряда чтобы получить число в 8ричной системе счичления

 

140_{16} = 0001 0100 0000 _2 = 5 0 0 _8

 

53_{16} = 5 * 16^1 + 3 * 16 ^0 = 80 + 3 = 83_{10}

 

53_{16} = 0101 0011_2 = 1 2 3_8

 

104_{16} = 1 * 16^2 + 0 * 16 ^1 + 4 * 10^0 = 256 + 0 + 4 = 260_{10}

 

104_{16} = 0001 0000 0100 _2 = 4 0 4 _8

 

 

2) 2^{15} бит

 

= \frac{2^{15}}{2^3} = 2^{12} байт

 

= \frac{2^{12}}{2^{10}} = 2^2 = 4 килобайта

 

 

2^{23} бит

 

= \frac{2^{23}}{2^3} = 2^{20} байт

 

= \frac{2^{20}}{2^{10}} = 2^10 килобайт

 

= \frac{2^{10}}{2^{10}} = 1 Мегабайт

 

Ответить

Другие вопросы из категории

Помогите,пожалуйста,решить задачу!

Мой богатый дядюшка подарил мне один доллар в мой первый день рождения. В каждый день рождения он удваивал свой подарок и прибавлял к нему столько долларов,сколько лет мне исполнилось. Написать программу,указывающую,к какому дню рождения подарок превысит 100$.

Читайте также

Ввести три числа, найти их сумму, произведение и среднее арифметическое

Пример
Введите три числа
4 5 7
4+5+7=16
4×5×7=140
(4+5+7)÷3=5.333333

напишите программу которая в последовательности натуральных чисел определяет минимальное число кратное 3. знаю как написать программу

для максимального числа

var

a:integer;

b:longint;

begin

b:=0;

readln(a);

while (a<>0) do

begin

if ((a mod 3=0) and (a>b)) then

b:=a;

readln(a);

end;

writeln(b);

readln

end.

как для минимального??

С клавиатуры вводятся два натуральных числа N и K (0<N<=K<=200000). Требуется написать программу, которая находит сумму простых чисел,

расположенных между N и K(включая эти числа).
Пример входных данных: 2 5
Пример выходных данных: 10

Помогите по программе paskal : 1.дано целое число.напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора

результат

2.дано целое число.напишите,программу которая выводит на экран последнюю цифру данного числа,затем возводит ее в квадрат и выводит на экран монитора результат



Вы находитесь на странице вопроса "1) числа 140", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.