Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

ПОМОГИТЕ написать в паскале y=Σ x^2k *(2^k/k!) за рание СПАСИБО

10-11 класс

Mamanaen 26 нояб. 2016 г., 10:55:40 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Akalinka
26 нояб. 2016 г., 13:14:10 (7 лет назад)

y=\Sigma _{k=1}^n(x^{2k}* \frac{2^k}{k!})=\Sigma _{k=1}^nY_{x,k}; \\  \\ Y_{x,1}=2x^2; \ Y_{x,k}=Y_{x,k-1}* \frac{2x^2}{k}  , \ k=2,3,.. n

var
  x, yk, y: double;
  k, n: integer;

begin
  Write('Введите через пробел значения x и n: ');
  Readln(x, n);
  yk := 2 * sqr(x);
  y := yk;
  for k := 2 to n do
  begin
    yk := yk * 2 * sqr(x) / k;
    y := y + yk
  end;
  Writeln('y=', y:0:5)
end.

Тестовое решение:

Введите через пробел значения x и n: 2.7 6
y=21352.46798






+ 0 -
EDCECW
26 нояб. 2016 г., 15:07:30 (7 лет назад)

2^k делить на k!

+ 0 -
Maximok
26 нояб. 2016 г., 17:42:48 (7 лет назад)

там еще ниже суммы k=1

+ 0 -
Unicorn20037
26 нояб. 2016 г., 20:06:10 (7 лет назад)

Понятно, что ниже суммы 1, а выше?

+ 0 -
Ganneman
26 нояб. 2016 г., 22:18:01 (7 лет назад)

в верху n

+ 0 -
Sabit0330
26 нояб. 2016 г., 23:54:32 (7 лет назад)

Ясно, значит n и x должны задаваться

Ответить

Другие вопросы из категории

Надо разбить n человек на пары для турнира х. После проведения раунда надо ещё раз разбить на пары, так чтобы игроки не играли ещё раз с друг другом и при

этом все должны принимать участие в этом раунде. и так пока не пройдёт (n = 2*m) n - 1 раундов. Я потом этот алгоритм должен буду описать на Paskal.
Или доказать, что это невозможно

какого значение y:

a:=6; b:=2;
if a>b then y:=5*a;
y:=3*b;

Как получить прямой код числа 78 ?.

И получить дополнительный код числа -49?.

Какое из этих чисел самое большое?

756(в 13)
756(в 10)
756 (в 8)
756(в 16)
756(в 12)

Читайте также

Помогите написать решение Паскаль в ALGO. Задание 1) Для заданного X вычислить значение функций: Y= 1) корень из X в квадрате, если

x=2

2) "нет решений", если x=0

3) 3x в квадрате минус 5, если X=3,4,5,6.

Задание 2) - Составить алгоритм и программу

Написать программу, которая определяет по последней цифре числа последнюю цифру его квадрата.

Прошу написать полное решение программы,

Спасибо Заранее

Помогите написать программу в паскале. За ранее спасибо.

Задача на одномерный массив.

Задание 2.
Задан одномерный массив MAS2 [1..10].
Массив объявите как константу типа Integer размером [1..10] со следующими значениями: (-7, 89, 64, -43, 4, 6, 8, -12, 55, 99)
Замените все положительные элементы одномерного массива на их квадраты, а отрицательные удвойте.
Результат вывести на экран.
Вычислить сумму всех элементов нового массива и вывести на экран.

Исходный массив Новый массив
-7 -14
89 7921
64 4096
-43 -86
4 16
6 36
8 64
-12 -24
55 3025
99 9801
Сумма элементов нового массива 24835

Помогите написать в паскале!

Ввести три целых числа
x, y, z. Если хотя бы одно из них четное,

то
первому четному числу присвоить значение произведения этих чисел.



Сообразил только как определить чётное или нечётное число а как дальше не могу понять!


program Lab2;
var x,y,z: integer;
Begin

Writeln ('Введите число');
Readln (x);
if x mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (y);
if y mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');

Writeln ('Введите число');
Readln (z);
if z mod 2 = 0 then
writeln ('Это число чётное')
else //Иначе
writeln ('Число нечётно');
end.










Вы находитесь на странице вопроса "ПОМОГИТЕ написать в паскале y=Σ x^2k *(2^k/k!) за рание СПАСИБО", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.