Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

РЕШИТЕ В ПАСКАЛЕ: Принадлежит ли точка с известными координатами окружности с известным радиусом. Попытайся воспользоваться формулой: квадрат радиуса

10-11 класс

равен сумме квадратов координат

Oxioxi 14 дек. 2016 г., 5:12:22 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Okc83
14 дек. 2016 г., 6:16:44 (7 лет назад)

const e = 1e-5; // точность
var x, y, r, d :real;
begin
  readln(x);
  readln(y);
  readln(r); r := r*r;
  d := sqrt(sqr(x) + sqr(y));
  if abs(d - r) < e then
    writeln ('лежит на окружности')
  else if d < r then
    writeln ('попадает в круг')
  else 
    writeln('вне круга');
end.

+ 0 -
хорошая23
14 дек. 2016 г., 7:55:14 (7 лет назад)

центр окружности в (0,0)?

+ 0 -
Gvtdujcdtf
14 дек. 2016 г., 9:01:09 (7 лет назад)

Да

+ 0 -
Затрясу
14 дек. 2016 г., 9:41:27 (7 лет назад)

ваще красава пацан, щас скину еще с другого аккаунта

Ответить

Другие вопросы из категории

Надо разбить n человек на пары для турнира х. После проведения раунда надо ещё раз разбить на пары, так чтобы игроки не играли ещё раз с друг другом и при

этом все должны принимать участие в этом раунде. и так пока не пройдёт (n = 2*m) n - 1 раундов. Я потом этот алгоритм должен буду описать на Paskal.
Или доказать, что это невозможно

какого значение y:

a:=6; b:=2;
if a>b then y:=5*a;
y:=3*b;

Как получить прямой код числа 78 ?.

И получить дополнительный код числа -49?.

Читайте также

Составьте программу, определяющую, лежит ли точка с указанными координатами X, Y на окружности радиуса R с центром в начале координат.

Program Frankenstein;
var
x,y,r:integer;
Begin
Write('Введите координату X: ');
Readln(x);
Write('Введите координату Y: ');
Readln(y);
Write('Введите длину радиуса R: ');
Readln(r);
If (sqr(x)+sqr(y))=r
then writeln('Точка лежит на окружности!')
Else writeln('Точка не лежит на окружности!');
End.

Почему программа всегда показывает что точка не лежит на окружности, хотя на самом деле она лежит! Где я ошибся?

Точка задана своими координатами. Определить, принадлежит ли точка заданной области (включая границу). Формат входных данных Во входном файле записаны два

вещественных числа - координаты точки . Формат выходных данных В выходной файл необходимо вывести или в зависимости от ответа на вопрос задачи.

Примеры: Вход -3 2 Выход Yes

расписать в паскале: На плоскости расположена окружность R в центре с началом координат.Определить положение точки X с координатами (A,B) относительно

окружности (лежит ли точка внутри окружности на окружности или вне ее) Если можно полностью



Вы находитесь на странице вопроса "РЕШИТЕ В ПАСКАЛЕ: Принадлежит ли точка с известными координатами окружности с известным радиусом. Попытайся воспользоваться формулой: квадрат радиуса", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.