Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Определить, принадлежит ли точка M с координатой x отрезку [a, b] числовой прямой. Значения x, a ,b вводятся с клавиатуры.

10-11 класс

Oliamorenets 17 окт. 2014 г., 16:47:40 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Yanchikmamichev
17 окт. 2014 г., 18:39:55 (9 лет назад)

var
a,x,b:real;
begin
   readln(x,a,b);
if a>b then
   if (x<=a)and(x>=b)then
      writeln('Yes')
   else
       writeln('No')
else
    if (x<=b)and(x>=a) then
         writeln('Yes')
    else
         writeln('No');
end.

Ответить

Другие вопросы из категории

Сложите следующие числа:

11000111(2) + 11100100(2) + 100101002 = ...(2)
Прошу с подробным решением))

ДАМ 34 ПУНКТА ПОМОГИТЕ СРОЧНО

составить программу на языке паскаль
Составить программу для вычисления значения функции z при вещетвенных значениях свех переменных
После запуска Программы ввести следующие значения x=1.5,y=-2.4

Читайте также

Точка задана своими координатами. Определить, принадлежит ли точка заданной области (включая границу). Формат входных данных Во входном файле записаны два

вещественных числа - координаты точки . Формат выходных данных В выходной файл необходимо вывести или в зависимости от ответа на вопрос задачи.

Примеры: Вход -3 2 Выход Yes

Вариант 5. Точка на плоскости задана своими координатами X и Y. Построить таблицу, содержащую координаты пяти точек, для каждой

из которых необходимо определить, принадлежит ли точка заштрихованной области.

Помогите составить программу. Даны действительные числа х и у, Определить принадлежит ли точка с координатами х,у заштрихованной области. Рисунок

предоставляю.
мне просто надо словами описать как это делать. (ну или условие if и тп и тп.)



Вы находитесь на странице вопроса "Определить, принадлежит ли точка M с координатой x отрезку [a, b] числовой прямой. Значения x, a ,b вводятся с клавиатуры.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.