Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дна последовательность неотрицательных чисел, последнее из которых Равно нулю: причем других равных нулю чисел в последовательности нет. Найти

10-11 класс

последнее число, больше десяти, в этой последовательности. Если таких чисел нет, напечатать ноль.

Katya53 21 июля 2014 г., 14:49:43 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vfrfrfr
21 июля 2014 г., 15:23:31 (9 лет назад)

var a, k: real
BEGIN
uses crt; clrscr;
write ('Vvedite 1 chlen posledovatelnosti'); readln (a);
k:=0;
while a > 0 do
begin
if (a > 10) then k := a;
write ('Vvedite ocherednoy chlen posledovatelnosti'); readln (a);
end;
writeln (k);
END.

Ответить

Другие вопросы из категории

Найти сумму

элементов массива с четными индексами, значение которых превышает К.(паскаль)

Программа 4. Пользователь вводит угол . Написать программу, доказывающую основное тригонометрическое тождество. Программа 5. Пользователь вводит

число рядов. Написать программу подсчета мест в кинотеатре «Оскар», в соответствии со схемой кинотеатра, представленной ниже. На экран вывести итоговое количество мест.(вложение - 1 рисунок)

Программа 6. Найти значение выражения для вводимых с клавиатуры А, В и С. при А=4, В=2, С=5.(вложение - формула)

Программа 7. Написать программу, вычисляющую значения логического выражения . На экран вывести это значение.

Программа 8. Пользователь вводит число 0,515625. Написать программу, которая в точности повторяет алгоритм перевода данного числа из десятичной системы счисления в четверичную. На экран вывести окончательный результат.

Читайте также

Поле шахматной доски представляется парой натуральных чисел, каждое из которых не превосходит восьми: первое число - номер вертикали (при счете снизу

вверх), второе - номер горизонтали (при счете слева направо). Даны натуральные числа k, l, m,n, каждое из которых не превосходит восьми. Требуется:

1. выяснить, являются ли поля (k, l) и (m, n) полями одного цвета

2. на поле (k, l) расположен ферзь. Угрожает ли он полю (m, n)?

задача в Delphi.

Даны

четыре целых числа, одно из которых отлично от трех других, равных между собой.
Вывести порядковый номер этого числа

1.Напишите программу, которая в последовательности натуральных чисел

определяет количество чисел, кратных 4. Программа получает на вход
количество чисел в последовательности, а затем сами числа. В
последовательности всегда имеется число, кратное 4. Количество чисел не
превышает 1000. Введённые числа не превышают 30 000. Программа должна
вывести одно число — количество чисел, кратных 4.

2. Напишите программу, которая в последовательности натуральных чисел определяет минимальное число, кратное 3. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 3. Количество чисел не превышает 1000. Введённые числа не превыша ют 30 000. Программа должна вывести одно число — минимальное число, кратное 3.

Известна математическая задача: " Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7" А Вы попытайтесь

написать программу, которая отвечает на вопрос " существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"

Входные данные: Два числа N(1<=N<=10000000000),k (1<=k<=100)
Выходные данные: Программа выводит два таких числа, если они существуют,"NO"- если нет.

Известна математическая задача: "Существуют ли два последовательных натуральных числа, сумма цифр каждого из которых делится на 7?" Напишите программу,

которая отвечает на вопрос: "Существуют ли два последовательных числа, не превосходящих N, сумма цифр каждого из которых делится на k?"
Входные данные. Два числа N (1 \leq N \leq 10000000000), k (1 \leq k \leq 100)
Выходные данные. Программа выводит два таких числа, если они существуют, "NO" - если нет.



Вы находитесь на странице вопроса "Дна последовательность неотрицательных чисел, последнее из которых Равно нулю: причем других равных нулю чисел в последовательности нет. Найти", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.