Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

По введенному года рождения рассчитать возраст человека и отнести его к одной из 4-х групп:дошкольник,ученик,работник,пенсионер. не могу решить

10-11 класс

Amali777 09 мая 2015 г., 14:44:57 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikonlord
09 мая 2015 г., 17:38:07 (9 лет назад)

var l:integer;

begin

readln(l);

if 2012-l<7 then writeln('doshkol'nik');

if (2012-l<19) and (2012-l>=7) then writeln('shkolnik');

if (2012-l>=19) and (2012-l<50) then writeln('rabotnik');

if 2012-l>=50 then writeln('pensioner');

end.

Ответить

Читайте также

Четыре друга, Николай, Борис, ДмитрийЧетыре друга, Николай, Борис, Дмитрий и Максим живут в одном

дворе. Одному из них 12 лет, другому 14, третьему 16, самому старшему
19. Они все увлекаются программированием, но каждый из них
специализируется только на каком-то одном из языков программирования:
Бейсик, Паскаль, Си, Хаскел. Определите имя и любимый язык
программирования 14-ти летнего программиста, если известно, что:
Возраст Димы отличается от возраста любителя Си не более чем на 2 года.Специалист по Хаскелу старше любителя Си.Не менее чем один из приятелей родился между годом рождения Бориса и годом рождения Димы.Юноша, пишущий на Бейсике либо самый старший из друзей, либо самый младший.Коля не пишет на Бейсике и его возраст больше чем на 2 года отличается от возраста любителя Бейсика.Любитель Бейсика родился с разницей в 2 года со специалистом по Паскалю.Борис старше программиста на Паскале.Знаток Паскаля младше специалиста по Си.
В ответе сначала запишите первую букву имени 14-ти летнего
программиста, затем через пробел первую букву его любимого языка
программирования.

ПОМОГИТЕ, ПОЖАЛУЙСТА!!

Ребят помогите ПОЖАЛУЙСТА! не могу решить задачу по информатике. Найти все трехзначные числа, которые при увеличении на 1 делятся на 2, при увеличении

на 2 делятся на 3, при увеличении на 3 делятся на 4, при увеличении на 4 делятся на 5. Буду очень благодарна!!!!

Введите с клавиатуры текущий год и год рождения. Вычислите возраст, если он меньше 18 вывести год совершеннолетия, а если больше, то год выхода на

пенсию. вывести текущий месяц и месяц рождения. Вычислить возраст в месяцах) дата рождения 11.03.1998

Создать на Паскале форму.

1. Население некоторой страны в 1904 году составляло а человек. По переписи населения, проведенной в прошлом году, зарегистрировано b человек. Составить программу вычисления среднегодового прироста населения за этот период.
2. Составить программу определения, является ли введенный год високосным?
3. Составить программу определения размера денежного вклада через t лет после его внесения, если заданы размер начального взноса n и банковский процент b.
4. Для условий из предыдущей задачи определить, через сколько лет размер вклада превысит вдвое первоначальный взнос.



Вы находитесь на странице вопроса "По введенному года рождения рассчитать возраст человека и отнести его к одной из 4-х групп:дошкольник,ученик,работник,пенсионер. не могу решить", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.