Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Элементы массива, номера которых кратны 3 увеличить в 2 раза. Паскаль ABC СРОЧНО! ПОЖАЛУЙСТА!

10-11 класс

Alinka02102000 23 окт. 2013 г., 7:53:00 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Karg077
23 окт. 2013 г., 10:18:12 (10 лет назад)

var
a: array[1..9999] of integer;
i, n: integer;
begin
randomize;
Write('Введите число эементов массива: '); readln(n);
for i:=1 to n do
begin
a[i]:=-999+random(1001);
write('a[', i, ']=', a[i]);
if a[i] mod 2 = 0 then write(' - кратно 3')
else write(' - не кратно 3');
writeln;
end;
writeln('Увеличим номера чисел, кратных 3, в 2 раза:');
for i:=1 to n do
begin
if a[i] mod 2 = 0 then
begin
a[i]:=a[i]*2;
writeln('a[', i, ']=', a[i]);
end;
end;
end.

Ответить

Другие вопросы из категории

Помогите с информатикой!

Это задания В14 в ЕГЭ

Задача на C++.

Для прямоугольной комнаты размером W x H метров нужно закупить линолеум. В магазине линолеум продают рулонами; вам известно количество квадратных метров линолеума в одном рулоне и цена рулона.

Требуется определить, хватит ли имеющейся суммы денег на покупку линолеума.

Линолеум также может быть закуплен у иностранного поставщика, поэтому требуется узнать его стоимость в иностранной валюте, курс которой по отношению к рублю известен.

Входные данные
Первая строка содержит два целых числа W и H (1 <= W, H <= 1000) — соответственно длину и ширину комнаты в метрах.

Вторая строка содержит два целых числа K и P (1 <= K, P <= 1000) — соответственно количество квадратных метров линолеума в одном рулоне и цену одного рулона в рублях.

Третья строка содержит одно целое число M (1 <= M <= 10^6) — количество имеющихся денег в рублях.

Четвёртая строка содержит одно вещественное число T (0 < T <= 10) — стоимость рубля в иностранной валюте.

Выходные данные
В первой строке выведите два целых числа — количество рулонов линолеума, которое потребуется приобрести, и общую стоимость линолеума в рублях.

Во второй строке выведите "YES" (без кавычек), если имеющихся денег хватит на покупку линолеума, иначе выведите "NO" (без кавычек).

В третьей строке выведите одно вещественное число с четырьмя знаками после запятой — общую стоимость линолеума в иностранной валюте.

Читайте также

Программирование в VBA. Задача:Массив сотоит из двадцати элементов. Сколько элементов массива нужно сложить (начиная с первого), чтобы сумма превысила

число 100. Вот моя программа:

Private Sub CommandButton1_Click()
Dim C(1 To 20) As Integer
Dim I, N, S As Integer
For I = 1 To 20
C(I) = Cells(I, 1)
Next I
S = 0
N = 0
For I = 1 To 20
If S <= 100 Then S = S + C(I) And N = N + 1
Next I
Cells(2, 3) = "Количество элементов массива, сумма которых превышает 100=" & N
End Sub

как результат выводит "0" (т.е. N заданное изначально). Может, кто-то сможет подсказать ошибку? Это срочно!

дан целостный массив из 30 элементов. элементы массива могут принимать целые значения от 0 до 100 опишите на русском языке или одном из языков

программирования алгоритм позволяющий найти и вывести номер элемента массива имеющего максимальное значение сре элементов массива которые делятся на 3 и кратны 5

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, позволяющий найти и вывести сумму элементов массива, кратных тринадцати. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого делится на тринадцать. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.


const N=30;
var a: array [l..N] of integer;
i,j,s: integer;
begin
for i:=l to N do readln(a[i]);
...
end.

Дан целочисленный массив из 10 элементов.Элементы массива могут принимать целые значения от -50 до 50.Составить программу ,позволяющую найти и

вывести сумму элементов массива которые кратны 7 и оканчиваются на 5 .Гарантируется,что в исходном массиве есть хотя бы один такой элемент.
НА ЯЗЫКЕ ПАСКАЛЬ!!!!

1) найди последний элемент массива меньше заданного числа

2) найди наибольший элемент одномерного массива
3) найти произведение элементов массива целых чисел от 1 до N, которые кратны 9
4) найти сумму чисел, имеющие нечетные номера
5) найти сумму наименьшего и наибольшего элементов массива
И ЭТО ВСЕ В ПАСКАЛЕ!!!!!!!



Вы находитесь на странице вопроса "Элементы массива, номера которых кратны 3 увеличить в 2 раза. Паскаль ABC СРОЧНО! ПОЖАЛУЙСТА!", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.