Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Определить, сколько фамилий в списке состоят из 8 или 9 букв. (тема: строковый тип данных)

10-11 класс

арсен25112004 11 нояб. 2014 г., 12:09:29 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Doctor93
11 нояб. 2014 г., 15:03:10 (9 лет назад)

Это без использования файлов

var spisok:array [word] of string; {объявляем массив для хранения фамилий}
n,i,k:word; {n - количество фамилий,i - вспомогательная переменная, k - количество фамилий в списке равных 8 или 9 буквам}

begin
write('Введите количество фамилий в списке n = ');readln(n);
for i:=1 to n do begin
write('Введите фамилию ',i,' :');
readln(spisok[i]);
if (length(spisok[i])=9) or (length(spisok[i])=8) then inc(k); {inc(k) - это тоже самое ,что k:=k+1; }
end;
writeln('Количество фамилий в списке состоящих из 8 или 9 букв = ',k);
end.

 

П.С. если вам потребуется,обработка конкретно через фаил напишите мне, так как в условии вы не указали точно через что!

 

 

+ 0 -
Lena137
11 нояб. 2014 г., 18:02:51 (9 лет назад)

Как по мне то лучше удобство и ничего лишнего, ведь список сохранять не говорили

 

var s:string;

k:integer;

Begin
  repeat
    write('Введите фамилию:');
    readln(s);
    if (length(s)=9) or (length(s)=8) then

      k:=k+1
  until s=''; {прекращаем чтенье если нам посылают пустую строку}
  writeln(k);
End.

 

 

Ответить

Другие вопросы из категории

Поменять местами содержимое ячеек массива с максимальным и минимальными значениями.

Пожалуйста, помогите с информатикой:(

ПОМОГИТЕ ПОЖАЛУЙСТА, СРОЧНО!

Даны целые положительные числа m,n и k. сформировать целочисленную матрицу размером m*n, у которой все элементы имеют значения k+i+j (i=1,2..m; j=1,2..n)

Читайте также

1. Определить, сколько байт содержится в 0.125 Гбайтах. Результат представить как возведенное в степень число 2.

2. Определить, сколько Гбайт содержится в 512 байтах. Результат представить как возведенное в степень число 2.

16. Цепочки символов (строки) создаются из букв латинского алфавита по следующему правилу: Первая строка состоит из двух символов – это буквы «AB».

Каждая из последующих цепочек создается такими действиями: в начало записывается буква, следующая по алфавиту за первой, далее записывается предыдущая строка и она же в обратном порядке символов (справа налево). Вот первые 4 строки, созданные по этому правилу:

(1) AB

(2) BABBA

(3) CBABBAABBAB

(4) DCBABBAABBABBABBAABBABC

16.1. С какой буквы начинается 13-я строка?

16.2. Сколько раз буква А встречается в 10-ой строке?

16.3. Какая буква стоит на 8-ой позиции в 11-ой строке?

16.4. Сколько раз встречается буква А в первых семи строках (суммарно)?

Нужно написать программу... Задание: Адрес, запрашиваемый пользователем, обычно состоит из четырех частей, из которых первые три

являются доменными именами различного уровня и разделены точками, а последняя отделена от них двоеточием и является портом, к которому обращается пользователь. Например, при обращении пользователя к www.ifmo.ru:8080 слово ru является доменным именем первого уровня, слово ifmo — доменным именем второго уровня, слово www — доменным именем третьего уровня, а 8080 является портом.

Вам необходимо по списку запросов пользователей в таком формате перечислить все различные порты, к которым обращались пользователи.

Формат входного файла

В первой строке входного файла input.txt находится одно натуральное число n (1 ≤ n ≤ 100) — количество адресов в данном вам списке. В следующих n строках содержатся сами адреса в формате, описанном выше.

Все доменные имена всех уровней состоят только из строчных букв латинского алфавита, а порты — только из цифр. Длина любого данного вам адреса не превышает 250 символов.

Формат выходного файла

В первой строке выходного файла output.txt выведите одно целое число k — количество различных портов, к которым обращались пользователи. В следующих k строках выведите сами порты. Каждый порт должен быть выведен ровно один раз в отдельной строке. Порты могут быть выведены в любом порядке.

Пример входных и выходных данных

input.txt


3
www.ifmo.pl:3389
www.ya.pl:65535
www.ifmo.kz:3389

output.txt

2
65535
3389

1) Сколько следует задать вопросов и как их следует формулировать, чтобы количественно оценить сообщение о том, что вагон стоит на одном из 16 путей?

2) Вы бросаете два кубика с нанесенными на гранях цифрами от 1 до 6. Определите, сколько битов информации несет сообщение о том, что на одном кубике выпала тройка, а на другом- пятерка.
3) Предположим, вероятность того, что вы получите за контрольную работу оценку "5", равна 0,6; вероятность получения "4" равна 0,3; вероятность получения "3"-0,1. Определите, сколько битов информации будет нести сообщение о результатах контрольной работы в каждом из вариантов. ПОЖАЛУЙСТА, ПОМОГИТЕ!!!



Вы находитесь на странице вопроса "Определить, сколько фамилий в списке состоят из 8 или 9 букв. (тема: строковый тип данных)", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.