Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Написать программу в паскале которая будет выводить два наибольших четных элемента массива [1..10]

10-11 класс

Ulbosn 03 дек. 2015 г., 7:34:15 (8 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Andrey2003752
03 дек. 2015 г., 9:56:30 (8 лет назад)

var i,max,max1:integer;
a:array[1..10] of integer;

begin cls;
for i:=1 to 10 do a[i]:=i;
max:=a[1];
max1:=a[2];
for i:=1 to 10 do
if ((i mod 2=0) and ( max < a[i] )) then
begin
max1:=a[i]-2;
max:=a[i];
end;
writeln(max,' ',max1);
readln;
end.

 

ну примерно так

Ответить

Другие вопросы из категории

Световое табло состоит из лампочек,каждая из которых может находиться в двух состояниях ("включено" или "выключено").Какое наименьшее количество лампочек

должно находится на табло,чтобы с его помощью можно было передать 400 разных сигналов?

Читайте также

Написать Программу в паскале которая посчитала бы 5^123 (это цикл как бы должен быть)

http://primat.org/index/0-128 вот сайт что бы написать программу.

Написать программу в Паскале.

Указания: Заполните одномерный числовой массив А[15] случайными целыми числами в интервале [18;15].Выведите значения элементов массива сначала в столбик,а затем в строку,причем на каждый элемент отведите 4 позиции.
Задача: Заменить элементы массива,которые кратны пяти,на значение максимального элемента массива.

Написать программы на языке С++

1) С клавиатуры вводится 2 числа - целое и вещественное. Программа выводит их сумму на экран.
2) Написать процедуру, которая умножает число типа int на число типа float на число типа double и выводит результат на экран
3) Написать процедуру, которая будет выводить любой текст, являющийся ее аргументом
4) С клавиатуры вводится 5 символов поочередно, программа выводит на экран акроним к слову которая образует эти 5 символов



Вы находитесь на странице вопроса "Написать программу в паскале которая будет выводить два наибольших четных элемента массива [1..10]", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.