Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Составить программу в Паскале. Ввести N чисел, и посчитать кол-во положительных и кол-во отрицательных

10-11 класс

Эвелина2015 20 апр. 2014 г., 14:29:37 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Nikosergey1989
20 апр. 2014 г., 17:21:13 (10 лет назад)

var n,x,neg,pos: integer;
begin
  write('n='); readln(n);
  while n>0 do begin
    n := n - 1;
    readln(x);
    if x < 0 then neg := neg + 1
    else if x > 0 then pos := pos + 1;
  end;
  writeln('положительных: ', pos);
  writeln('отрицательных: ', neg);
end.

Ответить

Другие вопросы из категории

какая ошибка в записи на языке паскаль?

x=0 and y<>8

Помогите решить две задачки (Паскаль)

Задание 1
В одномерном массиве случайных вещественных числе F(17) определить количество положительных элементов и их сумму.

Задание 2
В матрице L(5,5) случайных вещественных чисел определить максимальный элемент выше побочной диагонали, поменять его местами с элементом 2 строки 2 столбца.

Большая просьба расписать задачу подробно , хочу не просто списать решения , а понять его и научиться решать сам , огромное спасибо.

Читайте также

Составить программу Дан массив натуральных чисел , размерность -12 !) Заполнение массива производить с клавиатуры 2) Вывести на печать

только элементы кратные 2

3)Найти сумму первых пяти элементов

Составить программу Дан массив целых чисел , размерность -12

1) Заполнение массива производить случайными числами из диапозона [-10;35]

2)Вывести на печать только положительные элементы

3)Найти количество отрицательных элементов

Составить программу

Известны данные о выпуске прождукции ( ткани в метрах ) ткацким цехом текстильного комбината за каждый день месяца . Определить количество ткани ( метров) произведенных цехом за месяц .

1. Составить программу для нахождения наибольшего числа из трех чисел.

2. Составить программу для упорядоченное двух элементов по убыванию.



Вы находитесь на странице вопроса "Составить программу в Паскале. Ввести N чисел, и посчитать кол-во положительных и кол-во отрицательных", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.