Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Найти сумму(S) и произведение (P) всех чисел от 1 до 100 кратных 3

10-11 класс

Edmad2011dev 02 янв. 2017 г., 16:33:45 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Kirilliy
02 янв. 2017 г., 17:10:41 (7 лет назад)

Program asd;
USES crt;
Const n=5;
var A:array[1..n] of integer;
var p,s:real;  i:integer;
BEGIN
Clrscr;
For i:=1 to n do
 begin 
A[i]:=Random(100)+1; 
 Write(A[i]:4); 
end; 
P:=1; 
 For i:=1 to n do 
 begin 
 If A[i] mod 3=0 then   
begin   
S:=S+A[i]; 
P:=P*A[i]; 
end; 
 end; 
 Writeln;
  Writeln('Сумма матрицы: ',s,' Произведение матрицы: ',p);
END.

Ответить

Другие вопросы из категории

Пожалуйста,помогите!! решите задачи в Паскале 1. Дано слово из 12 символов поменять местами его треть следующим образом:первую треть слова разместить

на месте второй,вторую треть на месте третьей, третью треть-на месте первой. 2. Дано слово. Добавить к нему в начало четыре символа "+" и в конец пять символов "-"

помогите, пожалуйста!

Читайте также

Даны два целых числа А и В (А<В). Найти сумму всех целых чисел от А до В включительно Входные данные: ввести два целых числа А,В (1<=A,

B<=100).

Выходнфе данные: вывести сумму всех целых чисел от А до В включительно.

Можно, пожалуйста, с объяснением.

1)Написать программу вывода всех четных чисел от 2 до 1000 включительно

2)Написать программу определяющую сумму всех нечетных чисел от 1 до 99

1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа.

2.Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки.
3.Пользователем вводится 2 целых числа. Вывести на экран сумму положительных четных чисел, находящихся в границах диапазона, указанного пользователем.
4. В результате работы программы формируется массив, состоящий из 10 элементов и заполненный случайными числами от 0 до 100. Вывести на экран этот же массив в порядке возрастания.
5.Вводится строка, содержащая буквы и цифры разного регистра (т.е. строчные и прописные буквы). В результате работы программы на экран выводится строка следующего вида: цифры в порядке возрастания, строчные буквы по алфавиту, прописные буквы по алфавиту.



Вы находитесь на странице вопроса "Найти сумму(S) и произведение (P) всех чисел от 1 до 100 кратных 3", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.