Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Для заданного положительного e и заданного x вычислить сумму ряда с точностью e. Суммирование ряда завершается, если модуль очередного слагаемого меньше

10-11 класс

e. Определив тип общего члена ряда, и организовав вычисление его суммы со структурой вложенных циклов, получить таблицу, состоящую из переменных X, Y, S, при |X|<1.

Lal 28 дек. 2014 г., 1:16:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Stas3d3
28 дек. 2014 г., 2:01:16 (9 лет назад)

блин пришлось помучиться потому что формула написана в примере не правильно, не 2i+2, а 4i

var
    i: integer;
    sum, e, x, y, model: real;

begin
    read(x, e);
    i := 0;
    y := -1;
    repeat
        i := i + 1;
        y := y * -x * (4 * i - 3) / (4 * i);
        sum := sum + y;
        writeln(i:3, ' ', y:10:5, ' ', sum:10:5);
    until abs(y) < e;
    writeln();
   
    model := 1 - 1 / sqrt(sqrt(1 + x));
    writeln('Проверочное значение: ', model);
    writeln('Отклонение: ', abs(abs(sum) - abs(model)));
end.

Ответить

Другие вопросы из категории

Что такое растровая графика?

Выберите один ответ.
1), состоящее из отдельных объектов
2) изображение, состоящее из набора точек
3) изображение, содержащее большое количество цветов

что значит а <> 1 в паскале?

Читайте также

Задание 2 Тема: Ряды (циклы, итерации). Операторы DO используются для организации цикл

ических расчетов.

Цикл - это последовательность операторов, которая может автоматически выполняться более одного раза. Если количество повторов известно заранее (или может быть однозначно вычислено), используется оператор Цикл_с_параметром (DO «UNTIL»). Если количество повторов неизвестно, применяется оператор Цикл_с_Пред_условием (DO «WHILE»).

Вычислить сумму ряда:

a) с заданной точностью ξ и вывести количество итераций;

b) для 20-ти членов ряда.

Σ = 1/(1*3) + 1/(3*5) + 1/(5*7) + … ξ=0.0001 Ответ: 0.500

Последовательность чисел Фибоначчи образуется так: первый и второй члены последовательности равны единице, каждый следующий член равен сумме двух

предыдущих. (1,1,2,3,5,13...).Дано натуральное число n. n>=3. а)Найти k-й член этой последовательности; б)Для заданного n определить верно ли, что сумма первых n-членов последовательности есть четное число. Помогите, нужно составить программу для решения данных задач!

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "Для заданного положительного e и заданного x вычислить сумму ряда с точностью e. Суммирование ряда завершается, если модуль очередного слагаемого меньше", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.