Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Решите пожалуйста!!!

5-9 класс

Alisha555 30 июля 2013 г., 9:31:03 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Dosmarcet
30 июля 2013 г., 12:09:21 (10 лет назад)

program z1;
var a1, a2: integer;
begin
readln(a1, a2);
if a1 > a2 then writeln('a1');
if a2 > a1 then writeln('a2');
if a1=a2 then writeln('=')
end.

program z2;
var x: integer;
begin
readln(x);
writeln(x/(x+5));
end.

program z3;
var x: integer;
y: real;
begin
readln(x);
if x>0 then begin
y:=sqrt(x)+2;
end
else begin
if x<0 then begin
y:=sqr(x);
end
else y:=5;
end;
writeln(y);
end.

Если среда - FPC, то в вывод во 2 и 3 задачах добавить :4:4 ( Пример writeln(y:4:4);)

Ответить

Другие вопросы из категории

ПОЖАЛУЙСТА Составьте программу, запрашивающую 4-х значное число. И выходящую на экран сообщение :"Тысяч_, сотен_, десятков_, единиц_".Применяя функции

деления (Div и Mod)
2.Составьте программу делящую переменную А=100 на 3. Деление прекратить когда остаток А будет меньше 3. Подсчитать количество вариантов деления и вынести значение на экран.

Читайте также

Помогите пожалуйста с заданием.

Решите пожалуйста 3.11 номер

Решите пожалуйста 2 задачи!!! 1) Расставить между цифрами знаки арифметических операций (+, -, *, :) и , если надо, скобки так чтобы ответ

оказался равным 1:
1 2 3 4 5 6 7 = 1

2) Борисов, Кириллов, Данин и Савин – инженеры. Один из них – автомеханик, другой – химик, третий – строитель, четвертый - радиотехник. Известно, что:
1. Борисов, который обыгрывает в шахматы Данина и Кириллова, но проигрывает Савину, ходит на лыжах лучше Кириллова, который моложе его, и лучше радиотехника, посещает театр вдвое чаще, чем тот инженер, который моложе его и Кириллова;
2. Химик, который посещает театр вдвое чаще, чем автомеханик, не является самым молодым, а старше его только один из инженеров;
3. Строитель, который на лыжах ходит хуже, чем радиотехник, как правило, проигрывает в шахматных сражениях автомеханику;
4. самый старший из инженеров лучше всех играет в шахматы и чаще всех бывает в театре, а самый молодой лучше всех ходит на лыжах;
5. радиотехник – лучший шахматист и самый заядлый театрал, а автомеханик - лучший лыжник.
Назовите профессию каждого из инженеров.
Упорядочите лыжников и шахматистов по степени мастерства, начиная с наибольшей, и инженеров по возрасту, начиная с наибольшего.

Решите пожалуйста примеры!


Вы находитесь на странице вопроса "Решите пожалуйста!!!", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.