Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 977 ответов!

Помогите выполнить задание по ИКТ!! на программу Паскаль

5-9 класс

Написать программу подсчета количества элементов, если индекс ячейки нечетное число, а элемент ячейки-чётное

Jaytay 11 авг. 2014 г., 12:01:38 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BdmItryy
11 авг. 2014 г., 13:12:56 (9 лет назад)

var
  i,n:integer;
  a:array[1..20]of integer;
begin
writeln('Исходный массив:');
for i:=1 to 20 do
  begin
  a[i]:=random(10);
  if (i mod 2=1) and (a[i] mod 2=0) then n:=n+1;
  write(a[i],' ');
  end;
writeln;
writeln('Искомых элементов: ',n);
end.

Ответить

Читайте также

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

помогите пожалуйста!!!задание по информатике(паскаль)

Составить программу описания двух переменных чисел:трех действительн., трех целых, трех постоянных ,целые(2 чиловые ,1 символьная)
на уроке успели только 1 пример сделать:
Program _ Zadacha _1 ;
const_ s1=3
pi=3.14;
var_c2,c1:integer;
b2:real;
begin
end.

Помогите, пожалуйста, очень нужно! Срочно!:( 1) Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы

вычисления: а) y=x^10 б) y=x^15. Постараться использовать минимальное количество дополнительных переменных. 2) Дана сторона равностороннего треугольника. Найти площадь этого треугольника, его высоты, радиусы вписанной и описанной окружностей. Программу записать на языке Паскаль. 3) Дана величина А, выражающая объём информации в байтах. Перевести А в более крупные единицы измерения информации. Программу записать на языке Паскаль



Вы находитесь на странице вопроса "Помогите выполнить задание по ИКТ!! на программу Паскаль", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.