Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

найти и вывести сумму и произведение первых двадцати натуральных нечетных чисел

10-11 класс

ирина892987469 25 окт. 2013 г., 21:41:21 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
сема99
25 окт. 2013 г., 23:20:35 (10 лет назад)

Переменная "proizv" - это произведение, а "summa" - сумма. Я сделал так, чтобы выводились все эти 20 нечётных чисел, для удобства, но если не надо, то просто стирайте всю строку №14 (начиная считать от "program asd_;").
program asd_;
uses crt;
var i, b, summa : integer;
proizv : real;
a : array [1..20] of integer; 
BEGIN 
clrscr; 
b:=1; 
summa:=0; 
proizv:=1; 
for i:=1 to 20 do begin 
a[i]:=b;
b:=b+2;
writeln(a[i]);
end;
for i:=1 to 20 do summa:=summa+a[i];
for i:=1 to 20 do proizv:=proizv*a[i];
writeln('summa=',summa);
writeln('proizvedenie=',proizv);
END.

Ответить

Другие вопросы из категории

Составить приложение на языке Pascal. Вычислить на ПК значения функции, заданной в таблице. На печать

вывести значения вводимых исходных данных и полученные результаты,
сопровождая их именами переменных. Значения аргумента взять из
указанного диапазона так, чтобы протестировать все ветви программы.

Дана последовательность, содержащая от 2 до 30 слов, в каждом из от 1 до 8 символов строчных латинских букв между соседними словами-не менее одного

пробела, за последним словом-точка. Составить программу на языке Паскаль
1) Все слова, которые встречаются в последовательность по одному разу

Помогите решить срочно!!!
Представьте, что вы решили

помочь другу купить компьютеру. В магазине ему написали вот такой список:




Материнская плата GIGABYTE
GA-Z77-DS3H LGA 1155, ATX, Ret

Читайте также

Помогиииитееее!!!!

на паскале
1.Найти сумму первых 10 натуральных нечетных чисел.
2.Найти произведение натуральных чисел прекратить подсчет при вводе 1.

1. Заполнить массив с клавиатуры целыми числами. Вывести элементы этого массива на экран. (Добавить комментарии) 2. Заполнить массив таким образом, чтобы

каждый его элемент был равен утроенному значению его порядкового номера (индекса). 3. Ввести массив с клавиатуры, найти и вывести сумму элементов массива. 4. Ввести массив с клавиатуры, подсчитать, сколько в нем положительных элементов, а сколько отрицательных. 5. В одномерном массиве подсчитать, сколько отрицательных элементов находится на четных местах и сколько положительных на нечетных. 6. Элементы массива вводятся с клавиатуры, заменить в нем все отрицательные элементы их квадратами, а положительные кубами. Вывести на экран исходный и новый массив. 7. Ввести массив с клавиатуры, найти и вывести на экран максимальный и минимальный элементы. 8. Написать программу, которая определяет есть ли в массиве элемент введенный пользователем, подсчитывает их количество и выводит номер первого найденного элемента.

Составить блок-схему и

указать тип алгоритмов:Найти сумму первых десяти натуральных четных чисел.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 1000. Опишите на русском языке или на одном из языков

программирования алгоритм, позволяющий найти и вывести сумму элементов массива, кратных тринадцати. Гарантируется, что в исходном массиве есть хотя бы один элемент, значение которого делится на тринадцать. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них.


const N=30;
var a: array [l..N] of integer;
i,j,s: integer;
begin
for i:=l to N do readln(a[i]);
...
end.



Вы находитесь на странице вопроса "найти и вывести сумму и произведение первых двадцати натуральных нечетных чисел", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.