Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

НИ ЧЕГО НЕ ПОНИМАЮ,ЗАВТРА НАДО СДАТЬ,ПРОШУ,ПОМОГИТЕ!!!:( :(

5-9 класс

ИНФОРМАТИКУ НЕ ПОНИМАЮ,И ТЕМА НОВАЯ.
ВВЕСТИ С КЛАВИАТУРЫ МАССИВ ИЗ ДВАДЦАТИ ЦЕЛЫХ ЧИСЕЛ,ОБНУЛИТЬ ВСЕ ОТРИЦАТЕЛЬНЫЕ ЭЛЕМЕНТЫ,ВЫВЕСТИ МАССИВ НА ЭКРАН,ПОМЕНЯТЬ МЕСТАМИ ПЕРВЫЙ И ДВАДЦАТЫЙ ЭЛЕМЕНТ,ВЫВЕСТИ МОДИФИЦИРОВАННЫЙ МАССИВ.
ну пожалуйстаа:((((

Rozav 30 окт. 2013 г., 11:17:38 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Goidd
30 окт. 2013 г., 12:53:04 (10 лет назад)

var
    a: array[1..20]of integer;
    i, t: integer;

begin
    for i := 1 to 20 do
    begin
        read(a[i]);
        if a[i] < 0 then
            a[i] := 0;
    end;
   
    for i := 1 to 20 do
        write(a[i], ' ');
   
    t := a[1];
    a[1] := a[20];
    a[20] := t;
   
    for i := 1 to 20 do
        write(a[i], ' ');
   
end.

Ответить

Другие вопросы из категории

HELP!!

*Дан массив А целых чисел, состоящий из 20 элементов. Заполнить с клавиатуры.
1) Создать новый массив В, каждый элемент которого равен корню квадратному элемента массива А.
2)Найти сумму элементов массива с 11 по 15.
3) Найти элемент массива кратный 8 и его индекс.
4)Найти удвоенную сумму положительных элементов.
5)Вывести индексы тех элементов, значения которых больше значения предыдущего элемента( начиная со второго).
6) Определить, есть ли 2 пары соседних элементов с одинаковыми знаками.
7)Найти количество положительных элементов.
8)Вычесть из положительных элементов элемент с номером 2, а к отрицательным прибавить элемент с номером 4.
9) Удалить из таблицы все элементы массива, кратные 3 или 5.
10) Поменять местами второй элемент массива и первый чётный.
Помогите пожалуйста. Срочно нужно)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите

номер дня, на который пробег спортсмена составит не менее y километров. Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

4.Приведите примеры ситуаций в которых вы являетесь источником информации приемником информации.Какую роль за сегодняшний день вам чаще приходилось

выполнять?Обоснуйте ответы.
5.Приведите различные примеры процесса обработки информации.Определите по каким правилам она производится в каждом примере

Читайте также

ПОМОГИТЕ ПОЖАЛУЙСТА ..

если можно то объясните как , прошу . ни чеего не понимаю (
Перевести десятичное число 127 в двоичную систему



Вы находитесь на странице вопроса "НИ ЧЕГО НЕ ПОНИМАЮ,ЗАВТРА НАДО СДАТЬ,ПРОШУ,ПОМОГИТЕ!!!:( :(", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.