Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите

5-9 класс

номер дня, на который пробег спортсмена составит не менее y километров. Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Borisiq 28 сент. 2013 г., 16:52:27 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Arturelbakyan1
28 сент. 2013 г., 18:51:17 (10 лет назад)

var

  x, y:real;

  day:integer;

begin

  readln(x);

  readln(y);

  day := 1;

  while x < y do

  begin

    x := x * 1.1;

    day := day + 1;

  end;

  writeln(day);

end.

 

 

+ 0 -
Ylik13
28 сент. 2013 г., 21:06:45 (10 лет назад)

var
x,y:real;
n:integer;
begin
readln(x);
readln(y);
while x<y do begin
x:=x*0.1+x;
n:=n+1;
end;
writeln('den=', n)
end.

+ 0 -
Дарья
06 нояб. 2018 г., 17:29:53 (5 лет назад)

нужно еще задать начальное значение n, оно будет равно единице

Ответить

Другие вопросы из категории

4.Приведите примеры ситуаций в которых вы являетесь источником информации приемником информации.Какую роль за сегодняшний день вам чаще приходилось

выполнять?Обоснуйте ответы.
5.Приведите различные примеры процесса обработки информации.Определите по каким правилам она производится в каждом примере

Выберите образную модель:

а) фотография; б) схема; в)текст; г) формула

Читайте также

Помогите пожалуйста Решить 2 задачи на языке Паскаль! 1) По данному числу N распечатайте все целые степени двойки, не

превосходящие N, в порядке возрастания.

Операцией возведения в степень пользоваться нельзя!

2)

В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите номер дня, на который пробег спортсмена составит не менее y километров.

Программа получает на вход действительные числа x и y и должна вывести одно натуральное число.

Помогите решить задачу на языке программирования в Turbo Pascal, плиз Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он

увеличивал пробег на 10% от пробега предыдущего дня. Определить: а) ежедневное увеличение пробега лыжника за третий, четвёртый, ..десятый день тренировок; б) средний путь лыжника за первые 8 дней тренировок; в) сколько дней он будет бегать менее, чем по 15 км; г) в какой день суммарный пробег за все дни превысит 90 км.

Напишите, пожалуйста, программу на языке Паскаль

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый день он увеличивал норму на 10% от предыдущего дня. Какой суммарный путь пробежит спортсмен за 7 дней?

Turbo Pascal.

Спортсмен пробежал 10 км в первый день.Каждый следующий день он увеличивал норму на 10% от нормы предыдущего дня. Определить:
a) Через сколько дней он будет пробегать не более 20 км?
б) Сколько километров он пробежит на 7-ой день?

задача по информатике, составить блок-схему алгоритма и программу для решения задачи: спортсмен - лыжник начал тренировки пробежав в первый день 10 км,

каждый следующий день он увеличивал длину на Р% от пробега предыдущего дня, определить после какого дня суммарный пробег лыжника превысит 200 км. вывести найденное кол-во дней и их суммарный пробег.



Вы находитесь на странице вопроса "В первый день спортсмен пробежал x километров, а затем он каждый день увеличивал пробег на 10% от предыдущего значения. По данному числу y определите", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.