Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дан массив из 12 целых чисел,случайное число из промежутка [0;15]. Найти число меньше 7 увеличенное на 2. Я не понимаю как это делать, а сделать до

5-9 класс

завтра надо. Помогите пожалуйста, Зарание спасибо)

Annashaukina2 28 авг. 2013 г., 23:30:58 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Lolololololola
29 авг. 2013 г., 1:02:29 (10 лет назад)

Если я правильно понял :)

const n = 12;
var
  a: array[1..n] of integer;
  i, count, min: integer;
begin
  for i := 1 to n do begin
    a[i] := random(16);
    write(a[i], ' ');
    if(a[i] < 7) and (count = 0) then begin
      min := a[i];
      inc(count);
    end;
  end;
  writeln;
  writeln(min + 2);
end.

 

Ответить

Другие вопросы из категории

К устройству вывода графической информации относится:

1. дисплей
2. мышь
3. клавиатура
4. сканер
5. графический редактор

Укажите понятия,определяемые следующими словами(запишите в прямоугольниках).

а)Группа слов,которая выражает законченную мысль:
б)Значимая часть слова,которая стоит после корня и служит для образования новых слов:
в)Часть речи,которая указывает на предметы,признаки и количества,но не называет их:
Помогите пожалуйста!!Очень срочно нужно)*

Читайте также

1)Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2)Задан массив из 11 целых чисел. Посчитать количество нечётных

элементов массива.

3)задан массив из 9 целых чисел.Вывести на экран чётные элементы

Дан массив из N целых чисел a1,a2...,aN.Вам нужно проверить,есть ли в этом массиве три числа сумма которых равно нулю.

Формат входных данных

В певой строке входного файла содержится одно целое число n(1<=n<=200).Во второй строке находятся n целых чисел a1,a2...aN (-1000<=ai<=1000)-елементы массива.

Формат выходных данных

В единственной строке выходного файла выведите одно слово "YES",если в этом массиве есть три числа сумма которых равна нулю.Иначе выведите "NO".

1. Разработать схему алгоритма, который вводит массив из N целых

чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел.

2. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с чётными номерами. Протестировать алгоритм на произвольных массивах размерностью 5 и 8 элементов.

3. Разработать схему алгоритма, который вводит массив из N целых чисел и выводит на экран элементы с нечётными номерами в обратном порядке. Протестировать алгоритм для следующих исходных данных:

а) 1 3 5 6 8 9

б) -1 4 6 2 4 6 8 6 9

P.S. Убедительная просьба написать решение целиком и до наступления ночи. Я являюсь дилетантом в Паскале, а эти три задачи являются моим домашним заданием по информатике на завтра.

1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива.

2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива.
3. Массив из 5 целых чисел вводится с клавиатуры в строку. Найти сумму элементов массива, стоящих на чётных позициях. Вывести исходный массив и полученную сумму.
4. Массив из 40 целых чисел из промежутка [10,90] задается с помощью генератора случайных чисел. Найти сумму элементов массива, кратных n . Вывести исходный массив и полученную сумму.
Помогите кто в чем может.



Вы находитесь на странице вопроса "дан массив из 12 целых чисел,случайное число из промежутка [0;15]. Найти число меньше 7 увеличенное на 2. Я не понимаю как это делать, а сделать до", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.