Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Дан одномерный массив целых чисел.. Колличество чисел и их значения вводятся с клавиатуры . Индексация элементов массива начинается с единицы.

10-11 класс

Определить произведение элементов массива, которые являются отрицательными четными числами. Если аких чисел нет, то вывести на экран нуль

Onofriychuk73 15 нояб. 2016 г., 4:27:42 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Irinka013
15 нояб. 2016 г., 6:37:03 (7 лет назад)

var a:array[1..100]of integer;
i,s,n:integer;
c:boolean;
begin
readln(n);
for i:=1 to n do readln(a[i]);
s:=1;
for i:=1 to n do
if (a[i]<0)and(a[i] mod 2=0) then begin s:=s*a[i]; c:=true; end;

if c then writeln(s) else writeln(0);

end.

Ответить

Другие вопросы из категории

Дано натуральное число n. Определить сумму цифр во второй половине числа и сумму цифр в первой половине числа n.

(Пояснение к занятию: при решении задач целочисленной арифметики используются операторы цикла, операции mod и div.)

Помогите пожалуйста с программированием!!!

1) не надо
2)нужен только ответ
3)нужен только ответ
4)нужен только ответ
5) составить программу
6)составить программу
Помогите очень прошу!!!

написать в паскале используя циклы:

Среди всех натуральных трехзначных чисел найти и вывести на экран только кратные пяти и вычислить их количество.

Дан целочисленный массив из 30 элементов. Элементы массива могут принимать целые значения от 0 до 100. Опишите на русском языке или на одном из языков

программирования алгоритм , позволяющий найти и вывести произведение двузначных элементов массива, которые не делятся на 6.Гарантируется, что в исходном массиве есть хотя бы один такой элемент. Исходные данные объявлены так, как показано ниже. Запрещается использовать переменные, не описанные ниже, но разрешается не использовать часть из них. Исходные данные всегда подобраны так, что результат произведения не выходит за пределы объявленных типов данных.

Паскаль:
const N=30
var a : array [1..N] of longint;
i, j, p:longint;
begin
for i := 1 to N do
readln(a[i]) ;
...
end.

Для групповых операций с файлами используется маски имен файлов.

Маска представляет собой последовательность букв цифр и прочих
Допустимых в именах файлов символов в которых также могут
Встречаться следующие символы: Символ «?» (вопросительный
Знак) озночает ровно один произвольный символ. Символ «*»
(звездочка) озночает любую последовательность символов
Произвольной длины в том числе «*» может задавать и пустую
Последовательность . Определите по какой из масок будет
Выбрана указанная группа файлов
0999.txt, 9909.ppt, 0990.txt, 1990.ppt


a) ?0*.???
б) ?99*.*
в) *99*.?t
г) ?9??.???

Читайте также

Дан одномерный массив целых чисел, заполненный

случайным образом числами из промежутка [-40, 30]. Массив данных хранится в
файле. Удалить из него все элементы, которые состоят из одинаковых цифр.
Результат записать в другой файл.

Дан одномерный массив целых чисел размерностью 20.

Определите количество положительных групп в этом массиве.
(группа это последовательность состоящая из 2-х и более положительных чисел находящихся рядом.)

Паскаль помогите пжл!!!!!! Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива,

расположенных между максимальным и минимальным элементами.

Дан одномерный массив, состоящий из вещественных элементов. Найти произведение элементов массива, расположенных между максимальным по модулю и минимальным по модулю элементами

ну или исправьте мое пжл

program fgf;
var mas:array[1..100] of real;
max,min:real;
i,n,c,b:shortint;
p:real;
f1,g:text;
begin;
assign (f1, 'input.txt');
reset (f1);
readln (f1, n);

for i:=1 to N do read (mas[i]);
max:=mas[i];
for i:=2 to N do begin
if mas[i]>max then begin
max:=mas[i];
c:=i;
end;
end;
min:=mas[1];
for i:=2 to N do begin
if mas[i]<min then begin
max:=mas[i];
b:=i;
end;
end;
close(f1);
assign (g, 'output.txt');
rewrite (g);
p:=1;
if b<c then I:=b+1 and c-1

else for I:=c+1 to b-1 do p:=p*mas[i];

if (n<3) or (b+1=c) or (c+1=b) then writeln(g,'0.00') else write(p:3:3) ;

close (g);
end.



Вы находитесь на странице вопроса "Дан одномерный массив целых чисел.. Колличество чисел и их значения вводятся с клавиатуры . Индексация элементов массива начинается с единицы.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.