Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N

5-9 класс

Olyakiriluk 03 дек. 2013 г., 3:54:55 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
YanaYarechuk
03 дек. 2013 г., 6:08:10 (10 лет назад)

program Sum;

var

    a,b,c,s: integer;

begin

WriteLn('Введите числа а,в,с');

ReadLn(a,b,c);

s:=a+b+c;

WriteLn('Сумма чисел равна',s);

end.

+ 0 -
Ymnjazhka
03 дек. 2013 г., 8:32:28 (10 лет назад)

program Sum;

var

    a,s: integer;

begin

WriteLn('Введите трехзначное число а');

ReadLn(a);

While (a div 10>0)

begin

s:=s+ (a mod 10 );

a:=a div 10;

end

s:=s+a;

WriteLn('Сумма чисел равна',s);

end.

Ответить

Другие вопросы из категории

Помогите, пожалуйста! Нужно составить программу в СИ++.

Вывести квадраты и кубы 10 чисел следующей последовательности: 1, 2, 4, 7, 11, 16...

. Система команд исполнителя Вычислитель состоит из двух команд: 1 – прибавить 2 2 – умножить на 3. а) Составьте для Вычислителя алгоритм получения из

числа 2 числа 30. Алгоритм должен включать только команды 1 и 2, и состоять не более чем из 4 команд.

Читайте также

Пожалуйста помогите решить желательно все или хотя бы одну (P.S. программа для программы Turbo Pascal) 1.Написать программу, которая предлагает

ввести 3 значное число и находит сумму его цифр.

2. Написать программу, которая предлагает ввести 3 значное число и меняет порядок цифр наоборот. (123- 321)

3.Написать программу, которая предлагает ввести три числа с клавиатуры, находит их сумму, произведение и среднее арифметическое.

Помогите плиз срочно 1)Написать программу,которая спрашивает"Который час?" и,в зависимости от введенного времени,выводит приветствие:"Доброе

утро","Добрый день","Добрый вечер", "Спокойной ночи". 2)Написать программу,которая определяет,принадлежит ли точка с координатами (x,y)Заштрихованной области,ограниченной точками(x1,y1)(x2,y2).

Написать программу,которая вычисляет сумму первых n членов ряда 1,3,5,7. Количество суммируемых членов ряда задаётся во время роботы программы.

(ниже представлен рекомендуемый вид экрана во время работы программы)
Вычисление частичной суммы рада 1,3,5,7.
Введите количество суммируемых членов ряда: 15
Сумма первых 15 членов ряда равна 330.



Вы находитесь на странице вопроса "Написать программу которая найдет сумму цифр введенного с клавиатуры трехзначного натурального числа N", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.