Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Решить задачу: Паскаль DIM k,s AS INTEGER s=2 for k=3 to 5 s= 2+k+s next k print s

5-9 класс

Каким в итоге будет s?

ЮлияF 07 дек. 2013 г., 6:37:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Vendetta2
07 дек. 2013 г., 9:30:14 (10 лет назад)

S=2
k=3 
s=2+k(3)+2=7
Далее
S=7
k=4
s=2+k(4)+7=13
Далее
s=13
k=5
S=2+k(5)+13=20


Ответ S=20

Ответить

Другие вопросы из категории

в лыжной гонке участвуют 240 спортсменов. Специальное устройство регистрирует прохождение каждым из участников промежуточного финиша, записывая

номер участника цепочкой из нулей и единиц минимальной длины, одинаковой для каждого спортсмена. Каков будет информационный объём сообщения, записанного устройством, после того как промежуточный финиш пройдет половины лыжников?

Помогите, пожалуйста! Нужно составить программу в СИ++.

Вывести квадраты и кубы 10 чисел следующей последовательности: 1, 2, 4, 7, 11, 16...

. Система команд исполнителя Вычислитель состоит из двух команд: 1 – прибавить 2 2 – умножить на 3. а) Составьте для Вычислителя алгоритм получения из

числа 2 числа 30. Алгоритм должен включать только команды 1 и 2, и состоять не более чем из 4 команд.

Читайте также

Запишите значение переменной s, полученное в результате работы следующей программы. Текст программы приведён на трёх языках программирования.

Алгоритмический язык
Бейсик
Паскаль
алг

нач

цел s, k

s := 0

нц для k от 7 до 11

s := s+11

кц

вывод s

кон


DIM k, s AS INTEGER

s = 0

FOR k = 7 TO 11

s = s+11

NEXT k

PRINT s
Var s,k: integer;

Begin

s := 0;

for k := 7 to 11 do

s := s+11;

writeln(s);

End.

Решите задачу

Решите задачу с помощью рассуждения (рассуждения присылать тоже)
Задача: В одном доме живут 3 товарища: Вася, Боря и Дима.
Один из них играет в футбол, другой пишет стихи, а третий лучше всех играет в шахматы.
Известно : 1-ВАсин друг с огорчением сказал "Вчера я не сумел реализировать пинальти" 2-товарищ поэта сказал" Дима! Написал бы и ты что нибудь и для нашей футбольной команды"
Назовите имена футболиста, шахматиста, поэта (с рассуждением)

помогите решить задачу!!! Данычисла ,необходимо возвести во 2ую степень sin 1 числа и cos 2 числа.вот так как то


1
2
3
4
5
6
7
8
9
10

var i, n: integer;
p :real;
begin
write('Введите n: ');
readln(n);
p:= 1;
for i:= 1 to n do
p:= p*2;
writeln('Результат = ', р);
end.

Составить блок схему к программе:

Program name;
Const n=15;
var a: array [1..n] of integer;
i,p:integer;
begin
p:=1;
for i:= 1 to n do
begin
a[i]:=random(15);
write(a[i],' ');
end;
writeln;
for i:= 1 to n-1 do if a[i]+a[i+1]>10 then
begin
p:=0;
write(a[i],',',a[i+1],' ');
end;
if p=1 then writeln('NO');
end.



Вы находитесь на странице вопроса "Решить задачу: Паскаль DIM k,s AS INTEGER s=2 for k=3 to 5 s= 2+k+s next k print s", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.