Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

привет) препод говоит это очень простые задачи )) помогите решить пожалуйста потому что для меня они очень сложные!! 1) abs(10div12) 2) abs(sqr(

10-11 класс

17))

Zhaudir1982 16 июля 2016 г., 4:58:06 (7 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Jushverg
16 июля 2016 г., 7:05:57 (7 лет назад)

Abs - модуль числа.

div - целочисленный результат деления

mod - остаток от деления.

 

1) 10/12 = 0.8. Целый результат - 0. Модуль нуля тоже ноль.

2) корень из 17 - 4,12. Модуль - 4. 

+ 0 -
Aliferovskaya
16 июля 2016 г., 9:29:36 (7 лет назад)

1.) 10 div 12 = 0

abs(0) = 0;

2.) sqr(17) = 289

abs(289) = 289;

Ответить

Другие вопросы из категории

Читайте также

Для некоторых это будет легко,но для меня трудно.У меня идеи есть,но до сих пор не получается реализовать,чтобы все работало.

Я прошу помочь с выполнением задачи.
Напишите пожалуйста код в C++, который делает следующее:
Найти номер элемента массива,модуль разности сумм чисел слева и справа от которого наименьший.Значение элемента с этим номером при суммировании не учитывается.Номера элементов начинаются с 0.
Допустим элементы последовательности такие : 1,2,3,4,5,6,2.
Ответ:номер элемента 4.,т.е. это число 5 последовательности.
Помогите пожалуйста написать код.

Помогите решить задачу.

Дан массив А1,.......Аn. найти максимальный и минимальный элементы и поменять их местами. Вот задача которую я делал:

program zadacha;
const
k=50;
var
a:array[1..k] of integer;
n,i:1..k;
c,v,max,min,prom:integer;
begin
for i:=1 to n do begin (здесь выскакивает ошибка о проверки диапазона)
a[i]:=random(50);
write(a[i],' ');
end;
max:=a[1];
min:=a[1];
for i:=1 to n do begin
if a[i]>max then begin
max:=a[i];
c:=i;
end;
if a[i]<min the begin
min:=a[i];
v:=i;
end;
end;
writeln('max=',max,'min=',min);
prom:=max; (вот с этой строчки и до конца помогите решить)
max:=min;
min:=prom;
writeln;
writeln('Полученный массив');
for i:=1 to n do
write(a[i], ' ');
readln;
end.

Помогите глупому человеку, простейшая задача, а решить не могу.

Автоматическое устройство осуществило перекодировку информационного сообщения на русском языке, первоначально записанного в 8-битном коде, в 16-битную кодировку Unikode. При этом информационное сообщение увеличилось на 2048 байт. Каков был информационный объём сообщения в Кбайтах до перекодировки?
(Желательно с решением)
Заранее спасибо^^

Помогите решить на паскале

______________________________________
В сказочном Солнечном городе живут трое братьев: Ниф-Ниф, Наф-Наф, и Нуф-Нуф. Известно, что у каждого из них есть какое-то количество денег. Так случилось, что после физкультуры они перепутали пиджаки, в которых и лежали деньги. Однако зная о возможной путанице родители пришили бирки с именами. Помогите определить сколько же денег было до физкультуры у братьев, зная что Нуф-Нуф пришел домой в пиджаке Ниф-Нифа, а Наф-Наф в пиджаке Нуф-Нуфа. Входные данные:

В единственной строке входного потока, через пробел записано три числа в диапазоне от 1 до 10^9. Первое число это количество денег, которое обнаружил Ниф-Ниф в карманах придя домой. Второе - сколько стало у Наф-Нафа. И третье сколько принес домой Нуф-Нуф.

Выходные данные:

В первую строку выходного потока необходимо вывести сколько денег было у Ниф-Нифа, во вторую - сколько у Наф-Нафа, а в третью - сколько у Нуф-Нуфа.

Пример входного файла (input.txt): 32 22 54 Пример выходного файла (output.txt): 54 32 22



Вы находитесь на странице вопроса "привет) препод говоит это очень простые задачи )) помогите решить пожалуйста потому что для меня они очень сложные!! 1) abs(10div12) 2) abs(sqr(", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.