Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 979 ответов!

дано натуральное число n. Найти сумму первой и последней цифры этого числа

5-9 класс

леся324 14 марта 2015 г., 17:43:56 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Клэролайн
14 марта 2015 г., 20:25:08 (9 лет назад)

Возможно, не самое рациональное решение, но всё же.

Program n1;
Uses CRT;
Var n,k,ch,i,l,a,b,s: integer;
begin
ClrScr;
Writeln('Vvedite n');
Readln(n);
l:=n;
Repeat
k:=k+1;
n:=n div 10;
Until n=0;
ch:=1;
For i:=2 to k do
ch:=10*ch;
a:=l div ch; b:=l mod 10;
write(a+b);
readln
end.

Ответить

Читайте также

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число

не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2

1)найти сумму первых k последовательных нечетных чисел. написать программу в паскале. 2)вывести на экран натуральные нечетные числа от 5 до 55.тоже

паскаль 3)найти произведение последовательных натуральных чисел от n до m. написать программу паскаль. 4)найти сумму последовательных натуральных чисел от 10 до 15.тоже паскаль



Вы находитесь на странице вопроса "дано натуральное число n. Найти сумму первой и последней цифры этого числа", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.