Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

В Паскале:

5-9 класс

1.Составить функцию и процедуру, которая определяет сумму всех чисел от 1 до N.
2.Составить программу, которая определяет НОД и НОК двух чисел.

Almuhammederken 05 дек. 2014 г., 21:30:04 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Oleg555303
05 дек. 2014 г., 23:12:53 (9 лет назад)

1)
program gt;
var n,s:integer;
procedure  summa(n:integer;var s:integer);
begin
s:=((n+1)*n)div 2;
writeln(s);
end;
begin
read(n);
summa(n,s);
end.
1.2)
program gt2;
var n,s:integer;
function summa(n:integer):integer;
var s:integer;
begin
s:=((n+1)*n)div 2;
summa:=s;
end;
begin
read(n);
s:=summa(n);
writeln(s);
end.
2)program gt;
label 3,9;
var m,n,q,r,a,b:longint;
begin
read(m,n);
a:=m;b:=n;
3:
q:=m div n;
r:=m mod n;
if (r=0)then goto 9;
m:=n;
n:=r;
goto 3;
9:
m:=(a*b)div n;
writeln('НОД=',n);
writeln('NOK=',m);
end.

+ 0 -
Antoxa1999
05 дек. 2014 г., 23:59:50 (9 лет назад)

все решил. 1-задачу 2 способами

Ответить

Другие вопросы из категории

Реферат, набранный на компьютере, содержит 24 страницы, на каждой странице 72 строки, в каждой строке 48 символов. Для кодирования символов используется

кодировка КОИ-8, при которой каждый символ кодируется одним байтом. Определите информационный объём реферата.1) 18 байт
2) 81 байт
3) 18 Кбайт
4) 81 Кбайт

Читайте также

Помогите решить задачки на паскале я совсем не разбираюсь в этом!!! 1)Дана таблица со значениями среднемесячных температур в течение года. Составить

программу на Паскале, в которой вычисляются четыре величины: средние температуры зимних месяцев, весенних месяцев, летних и осенних. 2)Вы посетили магазин и купили 10 видов товара. В таблицу T [1..10] записали количество купленного товара каждого вида. В таблицу C [1..10] записали цену единицы каждого вида товара соответственно. Составить программу на Паскале вычисления общей стоимости всех покупок.

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Даны натуральное число n и вещественные числа a1, a2, ..., an. Определить среднее арифметическое вещественных чисел...

ПАСКАЛЬ,ПОМОГИТЕ ПОЖАЛУЙСТА

Паскаль, в его первоначальном виде, представляет собою чисто процедурный язык.

Простейшая программа на Паскале будет выглядеть следующим образом:
program upr;
begin
writeln ( ? ); {оператор вывода строки}
end.
Определи, какая фраза пропущена на месте вопросительного знака?
’Hello, World!’
“Lorem ipsum”
Just Another Perl Hacker

Найти алгоритм минимума из 3х целых чисел на паскале+ составить блок -схему.

ПОЖАЛУЙСТА,ХОТЯ БЫ НА ПАСКАЛЕ СОСТАВЬТЕ!

ПРОГРАММИРОВАНИЕ,ПАСКАЛЬ.РЕБЯТА,УМОЛЯЮ,ПОМОГИТЕ.

Задали написать программу на язвке паскаль:вычислить и вывести на экран 8 первых элементов ряда если каждый элемент задан формулой а1= i/sin*i



Вы находитесь на странице вопроса "В Паскале:", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.