Статистика
Всего в нашей базе более 4 327 664 вопросов и 6 445 978 ответов!

Составьте программу, которая вычисляет двухзначное число или нет.

5-9 класс

Irishkaivanova1996 22 нояб. 2013 г., 13:15:12 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Katerinapopova
22 нояб. 2013 г., 14:18:17 (10 лет назад)

Не знаю дошло сообщение нормально или нет, поэтому напишу здесь (язык с++) 

#include <cstdlib>
#include <iostream>
#include <math.h>
#include <stdio.h>
#include <conio.h>


int main()
{
int a = 0;
double division; //результат деления (с точкой)
 int result; (целая часть)
cout<<"Введите число"<<endl;
cin>>a;
division=a/10;
result=floor(division); //округление
if(result<10 && result!=0){
cout<<"Двузначное";
}
else
{
cout<<"Не двузначное";
}
return 0;

}

 

Здесь вводим число, делим его на 10, потом выделяем только целую часть из результата, если она не равна 0 и меньше 10 то число двухзначное.

Например ввели число

55, делим его на 10, получаем 5,5, округляем, получаем 5, это меньше 10 и не равно 0 значит число двухзначное.

Вводим число 5, делим его на 10, получаем 0,5, округляем, получаем 0, число не двухзначное.

Вводим число 114

Делим на 10 получаем 11,4, округляем получаем 11, это больше 10 не двухзначное 

Ответить

Другие вопросы из категории

Производится одноканальная (моно) звукозапись с частотой дискретизации 44,1 кГц и глубиной кодирования 16 бит. Запись длится 2 минуты,её результаты

записываются в файл , сжатие данных не производится. Найдите информационный объем полученного файла и выразите его в мегабайтах.

Читайте также

1)Составить программу которая выводит на экран каждое 5-ое число и таких чисел 20.

2)Составить программу которая вычисляет произведение натуральных чисел от 5 до 10.

1) составить программу , которая вычисляет суммы элементов столбцов двумерного массива и записывает их в одномерный

2-ая Составить программу , которая в двумерном массиве случайных чисел элементы всех четных строк делает нулевыми
язык паскаль

№1 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 и вычисляет произведение массива с четными

значениями. №2 Составьте программу, которая заполняет массив a[1..10] случайными целыми числами в диапазоне от 1 до 10 до 10 и вычисляет среднее арифметическое элементов массива. №3 Такое же как и №2, только ...элементов массива с четными значениями.

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди

элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве

1)Составьте программу,которая заполняет массив e[1..11] случайными целыми числами в диапазоне от -15 до 1 и находит количество элементов кратных 5.

2)Составьте программу,которая заполняет массив e[1..8] случайными целыми числами в диапазоне от 1 до 20 и находит сумму элементов с нечётными значениями и количество элементов кратных 3.
3)Составьте программу,которая заполняет массив e[1..14] случайными целыми числами в диапазоне от -10 до 10,затем изменяет знак положительных элементов на противоположный,а отрицательные элементы заменяет на 0.Спасибо.



Вы находитесь на странице вопроса "Составьте программу, которая вычисляет двухзначное число или нет.", категории "информатика". Данный вопрос относится к разделу "5-9" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.