Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

ВЫПОЛНИТЬ В ПАСКАЛЕ! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, имеется ли

10-11 класс

в записи числа N цифра «2». Если имеется, то вывести True, если нет — вывести False.

Заранее спасибо :3

Guldanat20055 10 марта 2014 г., 2:24:59 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Зефыч
10 марта 2014 г., 4:53:53 (10 лет назад)

var 

a,a1:integer;

check:boolean;

begin

check:=false;

readln (a);

while (a<>0) do

begin

a1:=a mod 10;

a:=a div 10;

if (a1=2) then check:=True;

end;

writeln (check);

 

end.

+ 0 -
Comboline
10 марта 2014 г., 6:32:16 (10 лет назад)

var
    num: integer;
    has2: boolean;

begin
    has2 := false;
    read(num);
    while (num <> 0) do
    begin
        if (num mod 10 = 2) then has2 := True;
        num := num div 10;
    end;
    writeln(has2);
end.

Ответить

Другие вопросы из категории

1.В произвольно заданном одномерном массиве ( случайные значения из отрезка -6 до 11 ) из 6 элементов, определить количество отрицательных, нулевых и

положитльных элементов.
2.
Сформируйте одномерный массив из 5 элементов (значения элементов укажт пользователь с клавиатуры). Обнулите значения всех элементов с нечетными индексами. Выведите значения одномерного массива в строку через пробел.

В соревнованиях по ориентированию участвуют 768 спортсменов. Специальное устройтсво регистрирует финиш каждого из участников, записывая его номер с исполь

зованием минимально возможного количества битов, одинакового для каждого спортсмена. Каков будет информационных объем сообщения (в байтах), записанного устройством, после того, как финишируют 200 спортсменов?

Напечатать перевод температуры из градусов по шкале Цельсия (С) в

градусы по шкале Фаренгейта (F) для значений температуры от 0
0С до 400С с
шагом 5
0С. Формула перевода F=1,8С+32.

Паскаль.Циклы с условием

Здравствуйте, прошу помогите решить такое вот чудо.

Решить вроде бы нужно найти что за число вместо x.
Кто знает как правильнее прошу вашей помощи.
Чтобы просмотреть фото, кликните на него.

Читайте также

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

Паскаль. Циклической структурой.

Дано целое число N (> 1). Вывести наибольшее целое К, при котором выполняется неравенство 3^K < N, и само значение 3^K
^ - степень.

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число



Вы находитесь на странице вопроса "ВЫПОЛНИТЬ В ПАСКАЛЕ! Дано целое число N (&gt; 0). С помощью операций деления нацело и взятия остатка от деления определить, имеется ли", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.