Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

Паскаль. Циклической структурой.

10-11 класс

Дано целое число N (> 1). Вывести наибольшее целое К, при котором выполняется неравенство 3^K < N, и само значение 3^K
^ - степень.

Alexandr1134086 20 июля 2014 г., 12:22:13 (9 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
BeTepaH
20 июля 2014 г., 14:26:09 (9 лет назад)

uses Crt;
var  b, n, k:integer;
begin
ClrScr;
write('Введите n=');
readln(n);   
b:=1; k:=0;   
while 3*b < n do   
begin     
k:=k+1;     
b:=b*3;   
end; 
writeln('k=', k, ' 3^k=', b);
readln;
end.

Ответить

Другие вопросы из категории

Напишите программу в паскаль для решения следующей задачи: для четырех произвольных чисел, введенных с клавиатуры, выведите на экран соответствующие

результаты. Если первое из них отрицательно, а второе вдвое больше третьего, то выведите среднее арифметическое всех четырех чисел. Если произведение этих четырех чисел больше их суммы, то выведите эти сумму и произведение. Если выполняются одновременно два перечисленных выше условия, то выведите среднее арифметическое этих чисел, их произведение и сумму. Иначе, выведите удвоенные значения этих чисел.

В чем ошибка? var x:real; fuction x1(a,b:integer):real; begin x1:=a+sqrt(b)/b+a; end; begin x:=

x1(15+8)/8+15 + x1(6+12)/12+6 + x1(7+21)/21+7;

writeln('x=', x:6:2);

end.

Читайте также

Помогите человеку с отвратительной фантазией 1. Составить задание на разработку программы линейной структуры в QBASIC

2. Составить задание на разработку программы на разветвляющиеся структуры в QBASIC

3. Составить задание на разработку программы циклической структуры в QBASIC

Нужно задание + сама программа

Выбрать правильный ответ. Многократно повторяющаяся часть программы (алгоритма) называется: Циклом; Логическим условием; Оператором;

Ничего из вышеперечисленного.

Бесконечный цикл: Можно остановить путем ввода данных пользователем; Приводит к останову программы Можно использовать для создания короткой паузы в выполнении программы; Приводит к повторению некоторой части программы, пока не будет нажата клавиша “СТОП”.

Можно организовать цикл, повторяющийся до тех пор, пока не выполнится логическое условие с помощью операторов: FOR … NEXT IF… THEN GOTO Все вышеперечисленное.

Содержащаяся одна в другой циклические структуры называются: Вложенными; Простыми; Последовательными; Ничего из вышеперечисленного.

Какая из следующих строк может быть начальной строкой цикла FOR…NEXT: FOR A$=1 TO 15 FOR A=1 TO 15 FOR A=1 TO=15 FOR 4A=1 TO 15

Цикл FOR…NEXT приводит к повторению некоторой части программы, которая носит название: Тело цикла; Глубина цикла; Параметр цикла; Приращение.

дан фрагмент программы

Y=0
FOR K:=15 DOWNTO 1 DO;
begin
Y=Y*K;
end;
напишите запись фрагмента программы, реализирующего алгоритм циклической структуры..
напишите пожалуйста полный ответ...))

РЕШИТЕ В ПАСКАЛЕ: "Циклический алгоритм "

В данной строке определить количество цифр.



Вы находитесь на странице вопроса "Паскаль. Циклической структурой.", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.