Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 978 ответов!

дано целое число m>1. получить наибольшее целое k, при котором 4^k(четыре в степени k)<m. на С#

10-11 класс

Kjfgfh 19 марта 2014 г., 20:49:23 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Svetocheva01
19 марта 2014 г., 23:05:11 (10 лет назад)

using System;

namespace _01_test{
    class Program
    {
        static void Main(string[] args)
        {
            int m, k = 0;
            m = Convert.ToInt32(Console.ReadLine());
            while (Math.Pow(4, ++k) < m);
            Console.WriteLine(k-1);
        }
    }
}

Ответить

Другие вопросы из категории

пользователь компьютера, хорошо владеющий навыками ввода информации с клавиатуры может вводить в минуту 100 знаков.Мощность алфавита, используемого в

компьютере равна 256. Какое количество информации в байтах может ввести пользователь за 1 минуту?

Паскаль. Смотрите Вложение.

Читайте также

Помогите пожалуйста решить 1) дано натуральное число. Определить номер цифры 3 в нем считая от конца числа. Если такой цифры нет то ответ

0,если их несколько то номер крайней правой.

2) Дано натуральное число. Определить сумму m его последних цифр

3)Дано натуральное число. определить его максимальную цифру.

4) дано предложение. заменить в нем все вхождения под строку str1 на подстроку str2

5) последовательность чисел Фибоначчи образуется так: первый и второй член последовательности равен 1, каждый следующий равен сумме двух предыдущих(1,1,2,3,5,,8,12..) Дано натуральное число n>=3 : а) найти k-й член последовательности б)получить первые n членов последовательности в)для заданного n определить верно ли,что сумма первых n членов есть четное число

Задачи паскаль, помогите пожалуйста кто. 1, Напишите программу, реализующую следующие вычисления. Дан номер месяца — целое число в диапазоне

1–12, введенное с клавиатуры (1 — январь, 2 — февраль и т. д.). Вывести название соответствующего времени года («зима», «весна», «лето», «осень»).

2, Напишите программу, реализующую следующие вычисления. Дана матрица размера M x N (числа вводятся с клавиатуры). Для каждого столбца матрицы найти произведение его элементов. Полученные значения вывести в текстовый файл.

3, Напишите программу с использованием функции CircleS(R) вещественного типа, находящей площадь круга радиуса R (R — вещественное). С помощью этой функции найти площади трех кругов с данными радиусами. Площадь круга радиуса R вычисляется по формуле S = πR2.

4, Напишите программу, реализующую следующие вычисления. Дано целое число N (1≤N≤26), введенное с клавиатуры. Вывести N первых прописных (то есть заглавных) букв латинского алфавита.

ВЫПОЛНИТЬ В ПАСКАЛЕ! Дано целое число N (> 0). С помощью операций деления нацело и взятия остатка от деления определить, имеется ли

в записи числа N цифра «2». Если имеется, то вывести True, если нет — вывести False.

Заранее спасибо :3

Паскаль. Циклической структурой.

Дано целое число N (> 1). Вывести наибольшее целое К, при котором выполняется неравенство 3^K < N, и само значение 3^K
^ - степень.



Вы находитесь на странице вопроса "дано целое число m&gt;1. получить наибольшее целое k, при котором 4^k(четыре в степени k)&lt;m. на С#", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.