Статистика
Всего в нашей базе более 4 327 663 вопросов и 6 445 976 ответов!

Укажите тип для переменной Х, если она предназначена для хранения : 1. Роста ученика 10 класса 2. Дата изготовления 3. Количество единиц товара на

10-11 класс

складе

Uljana32 13 янв. 2014 г., 16:39:57 (10 лет назад)
Рейтинг
+ 0 -
0 Жалоба
+ 0 -
Borisova1202200
13 янв. 2014 г., 18:42:27 (10 лет назад)

#include <iostream>
using std::cout;
using std::cin;
using std::endl;

void test(int);

int main()
{
int number;

cout << "Enter the number: ";
cin >> number;

if(number < 1000)
{
cout << "Error" << endl;
}
else
test(number);

return 0;
}

void test(int number)
{
int a, b, c;

c = number % 10;
number /= 10;

b = number % 10;
number /= 10;

 a = number % 10;


 cout << a << " * " << b << " * " << c << " = " << (a * b *c) << endl;}

Ответить

Другие вопросы из категории

пользователь компьютера, хорошо владеющий навыками ввода информации с клавиатуры может вводить в минуту 100 знаков.Мощность алфавита, используемого в

компьютере равна 256. Какое количество информации в байтах может ввести пользователь за 1 минуту?

Паскаль. Смотрите Вложение.
Написать программу построения указанной цветной

геометрической фигуры(паскаль)

ПОМОГИТЕ СРОЧНО!завтра экзамен



В фрагменте базы данных представлены сведения о родственных отношениях. Определите на основании приведённых данных, фамилию и инициалы внучки Колесника

П.Р.

1) Коваль Н.Т.

2) Колесник С.П.

3) Колесник Т.И.

4) Мороз В.И.

Объясните пожалуйста подробно, выбранный Вами ответ. Почему именно так

Читайте также

Помогите с тестами по информатике!!! А1. Определите значение целочисленных переменных a и b после выполнения фрагмента программы:

a := 3 + 3*4;

b := (a div 10) + 4;

a := (b mod 10) + 2;

b:= a + b;

a:= a mod 2 + b div 3;

1) a=4, b=14;

2) a= 24, b= 6;

3) a=5, b=12;

4) a=8, b=12.

А2. Для какого из указанных значений числа X истинно высказывание

((X < 5)→(X < 3)) Ù ((X < 2)→(X < 1))

1) 1

2) 2

3) 3

4) 4

А3. Укажите, какое логическое выражение равносильно выражению ¬(A Ú ¬B Ú C) ?

1) ¬A Ú B Ú ¬C

2) A Ù ¬B Ù C

3) ¬A Ú ¬B Ú ¬C

4) ¬A Ù B Ù ¬C

X

Y

Z

F

1

1

1

1

1

1

0

1

1

0

1

1

А4. Символом F обозначено одно из указанных ниже логических выражений от трех аргументов: X, Y, Z. Дан фрагмент таблицы истинности выражения F (см. таблицу справа).

Какое выражение соответствует F?

1) X Ú ¬Y Ú Z

2) X Ù Y Ù Z

3) X Ù Y Ù ¬Z

4) ¬X Ú Y Ú ¬Z

А5. Что будет выведено на печать в результате выполнения следующих операторов:

a := 5; b := 10;

write( 'сумма двух чисел ' ); write( 'a+b' );

write( ' = ', a+b );

1) сумма двух чисел 5+10 = 15

2) сумма двух чисел a+b = 15

3) сумма двух чисел 5+10 = a+b

4) сумма двух чисел a+b = 5+10

5) ни один из ответов 1-4 не верен

А6. Чему было равно значение переменной a, если после выполнения операций

b := sqrt( sqr(a+1) );

c := -b;

a := 1 + 2 / (c-b);

она стала равна 0 ?

1) 2

2) 0

3) –1

4) любое вещ. число, не равное -1

5) ни один из ответов 1-4 не верен

А7. Чему будет равно значение А после выполнения цикла

а:=1024;

While a>0 do

a:=a / 2;

1) 0

2) 1

3) зациклится

4) 512

5) ни один из ответов 1-4 не верен

A8. Сколько раз выполнится тело цикла?

A:=32;

While A>2 do

Begin A:=A / 2; writeln(‘A’); end;

1) 8

2) 6

3) 5

4) 4

5) 3

1) Правильно ли определён тип величины? a. количество тетрадей - вещественный тип b. кличка собаки - символьный тип с.

вес контейнера - целый тип

2) Укажите тип величины, если значение равно:

1. ‘компьютер’

2. 115

3. 0.15

3) Из приведённых значений выберите допустимые для величин и впишите в ячейки напротив подходящего типа: ‘55’; 30; -46; -0.126; ‘солнце’; 15.003; ‘g’

1. целого типа (BYTE)

2. вещественного типа

3. литерного (символьного) типа

4. строкового типа

5. целого типа (INTEGER)

1.Напишите команды, которые выполняют следующие действия: а) вывод переменной с ;б) описать переменные а и s целого типа; в) переменной r присваивает

разность чисел p и q.
2.Что будет на экране после выполнения следующих команд: а) Writeln(9); Write(5); Writeln(3); б) Writeln(4*2); Write('5-3'); Writeln('5+1=',5+1);
3.Укажите различия циклов While и Repeat
4.Дана строка. Определить сколько пробелов в этой строке
6.Дано четырехзначное число. Вывести на экран сумму цифр этого числа
7.Найти количество цифр целого числа N
8.Напишите команды, которые выполняют следующие действия: а) ввод переменной d б) описать переменные m и n вещественного типа. в) переменной s присвоить разность чисел p и q
9.Что будет на экране после выполнения следующих команд: Writeln(5-3); Write('5+3'); Writeln('5*4=',5*4);
10.Когда нельзя применять цикл for
11.Дана строка. Определить сколько букв в этой строке
12.Дано трехзначное число. Вывести на экран все его цифры столбиком
13. Найти количество цифр целого числа N(+блок-схема)

Уильям Вингейт предлагает услуги по учету пиццы. Для каждой пиццы он записы-

вает такую информацию:

• Имя компании-производителя пиццы, которое может содержать более одного слова

• Диаметр пиццы

• Вес пиццы

Придумайте
структуру, которая может хранить такую информацию, и напишите
программу, в которой используется переменная специального типа для такой
структуры. Программа должна предлагать пользователю ввести данные для
каждого из названных пунктов и затем выводить эту информацию.
Используйте объекты cin (или его методы) и COUt.

5. Напишите
программу к упражнению 2, но используйте оператор new для выделе­ния
структуре области памяти вместо объявления структурной переменной.
Про­грамма должна также запрашивать диаметр пиццы до запроса названия
компа­нии — производителя пиццы



Вы находитесь на странице вопроса "Укажите тип для переменной Х, если она предназначена для хранения : 1. Роста ученика 10 класса 2. Дата изготовления 3. Количество единиц товара на", категории "информатика". Данный вопрос относится к разделу "10-11" классов. Здесь вы сможете получить ответ, а также обсудить вопрос с посетителями сайта. Автоматический умный поиск поможет найти похожие вопросы в категории "информатика". Если ваш вопрос отличается или ответы не подходят, вы можете задать новый вопрос, воспользовавшись кнопкой в верхней части сайта.